Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
sophiabkb
New Member

Error after adding a custom column when loading rows

Hello everyone,

 

I am getting data from an API to build a dashboard. 

Everything was working perfectly fine until I added two more column with API custom function that fetch data based on a column id. 

I can visualise the data on Power Query but I have a red and white stripes bar. The error occurs when loading and says : 

OLE DB or ODBC Error : an exception type Microsoft.Mashup.Engine.Interface.ResourceAccessForbiddenException was thrown. 

 

I have tried to clear permissions and re enter the credentials but it didn't work. I am connecting with Basic Auth. 

 

I hope someone can help me, I can't understand why it worked before regarding it's the same credentials as before. 

3 REPLIES 3
sophiabkb
New Member

Yes, it does work when I take off the custom column. 

I create Two custom columns with API request using the same column parameter is it because of this ?

Do you get "access forbidden" only for some of the API calls?

 

You could choose to remove rows with errors, or replace errors. But the correct approach would be to fix the errors.

lbendlin
Super User
Super User

Does it work again when you remove these columns/custom function?

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.