Skip to main content
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Helper I
Helper I

API Refreshes Data Set 400 Bad Request error after first time



I am not able to find the problem with an API call to refresh a dataset. It worked once and it doesn't anymore. It gives a 400 Bad Request Error on GetResponse(). The call works if I do a GET which gives me the refresh history, no problem. The POST doesn't work after the first time it did.


The call is made by a WebApp that resides in Azure. The dataset is an import from Azure SQL.


The code is below:


protected void UpdateReport(int index)
// Create a request using a URL that can receive a post.
System.Net.WebRequest request = System.Net.WebRequest.Create("");
// Set the Method property of the request to POST.
request.Method = "POST";
request.Headers.Add("Authorization", String.Format("Bearer {0}", accessToken.Value));
// Set the ContentType property of the WebRequest.
request.ContentType = "application/x-www-form-urlencoded";
// Set the ContentLength property of the WebRequest.
request.ContentLength = 0;
System.Net.WebResponse response = request.GetResponse();
// Display the status.
System.IO.Stream dataStream = response.GetResponseStream();
// Open the stream using a StreamReader for easy access.
System.IO.StreamReader reader = new System.IO.StreamReader(dataStream);
// Read the content.
string responseFromServer = reader.ReadToEnd();
// Display the content.
txtResponseFromServer.Text = responseFromServer;
// Clean up the streams.

catch (Exception e)
txtResponseFromServer.Text = String.Format("An error occurred: '{0}'", e);


Any help is appreaciated.







Error 400 is an HTTP general error.



Try to replace the URL with the following:


Under the 




function, then check the results.




Hi again,


I tried with a new report. Again, it worked for a few times initially and now it doesn't work anymore with a 400 Bad Request error.



Could it be that you hit the refresh limit of 8 refreshes per day (or 48 in case of a workspace on a Premium node)?

Hi alexisc67,


This happened to me once but I don't remember if it was 400 bad request error. How many times do you refreshed it? The maximum ammount of refreshes in a day is 8. If you exceded it will stop to work.


If you need to refresh more than 8 times you should consider a streaming dataset.


Best regards,




Thansk for the response. I have tried using 'myorg' and also my company name in this place. I get the same result. Isn't strange that the GET works fine and the POST doesn't. Also, why worked once and not after.


If you can think of something else I can check, please let me know.



Helpful resources

Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.