cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
brenkehoe
Helper I
Helper I

ADGraphGroupOperationFailed error when creating groups

I am trying to create an app workspace (group) using the power bi rest api and recieve the following error:

 

{"error":{"code":"ADGraphGroupOperationFailed","pbi.error":{"code":"ADGraphGroupOperationFailed","parameters":{},"details":[]}}}

 

I have tried this using both a domain admin account and normal domain user.

 

Any ideas ?

12 REPLIES 12
Ran
Regular Visitor

Hello,

Can you share the body of the request?

Also - have you tried doing the same using the PowerBI SDK? (https://github.com/Microsoft/PowerBI-CSharp)

Request body is:

 

{
    "name":  "prm-buildout"
}

 

I have not used the sdk to try this as it is part of a deployment powershell script using REST. All other power bi calls work including get groups, import reports, set connections etc.

 

Actual response is:

 

{"error":{"code":"ADGraphGroupOperationFailed","pbi.error":{"code":"ADGraphGroupOperationFailed","parameters":{},"details":[]}}}

Please try using the PowerBI SDK for trouleshooting, to make sure you properly construct the request body.

 

Also - if you can share the response headers, i'll be able to look it up on our side.

 

resp-headers.PNG

@brenkehoe

I have the same error when testing creating a group via the POST API. What I obeserved is that, meanwhile I'm not able to create a group in Power BI Service as well. The reason can be that the Exchange admin have disabled your permission to create a group, see this thread.

 

The same API works when I test in my another account with sufficient perssion.

Not tested today but i did manage to create a workspace / group with the same user account through the power bi website last week. But never had any success using the REST API. I will try with the SDK now to see if the result is the same.

It does seem to create the workspace / group fine using the SDK with the same user account.

Please inspect the request that is being sent from the SDK (e.g. using fiddler) and compare it to the request you manually send

@Ran I don't seem to see any requests in fiddler when using the SDK. None that carry a request payload anyway. Need any special settings ?

It depends on how you use the SDK, please use the step described in http://docs.telerik.com/fiddler/Configure-Fiddler/Tasks/ConfigureDotNETApp to setup your calls to go through fiddler.

I finally got to the bottom of this by looking through the SDK code on github. The problem seems to be caused by not including the content type header. 

("Content-Type", "application/json; charset=utf-8")
 
The documentation however does not mention this is required from what i can tell: https://msdn.microsoft.com/en-us/library/mt784675.aspx
 
Thanks all for the help with this.

Thank you for your input, i'll make sure the docuemntation will be fixed.

Helpful resources

Announcements
PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!