Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

how can filter Report from blank values were using UNICHAR thresholds

Hi everyone,

any have any idea how can filter Report from blank values were using UNICHAR thresholds

 

without UNICHAR thresholds (Filter working)

 

unichar.png

with UNICHAR thresholds (Filter NOT working)

 

apply filter with Thresholds.PNG

 

how can i apply filter with UNICHAR thresholds?

2 ACCEPTED SOLUTIONS

HI, @Anonymous 

Just try this formula:

KPI_UTIL 2 = IF(ISBLANK(AVERAGE(AGTPRF_FCT_PERFORMANCE[UTILIZATION_PERCNT]))=FALSE(), UNICHAR(11044))

Result:

6.JPG

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Anonymous
Not applicable

Really appreciated @v-lili6-msft  🙂

 

Accept it as the solution

View solution in original post

12 REPLIES 12
v-lili6-msft
Community Support
Community Support

HI, @Anonymous 

Just try this formula to add a KPI UTL

KPI UTL = IF(ISBLANK([Avg of UTIL%])=FALSE(),UNICHAR(11044))

Result:

BeforeBeforeAfterAfter

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
jdbuchanan71
Super User
Super User

Hello @Anonymous 

Is your Utilization% done as a measure?  Is it possible that instead of being BLANK it is something like "" (an empty string) which looks blank but is not?

Would it be possible for you to share a sample .pbix file that has the behavior you are trying to fix?  It is always easier to trouble shoot and actual model.

Anonymous
Not applicable

as per my investegation,

Oracle DB Table which I am reading direct query from it 

doesn`t have any %' '% on the Measure of UTILIZATION_PERCNT :

 

select A.UTILIZATION_PERCNT from AGTPRF_FCT_PERFORMANCE a
--where A.UTILIZATION_PERCNT not like '%.%'
group by A.UTILIZATION_PERCNT
order by 1

 

Result: 46 -rows

 

0.17
0.19
0.23
0.25
0.33
0.34
0.38
0.41
0.44
0.55
0.58
0.6
0.61
0.67
0.68
0.69
0.7
0.71
0.72
0.73
0.74
0.75
0.76
0.77
0.78
0.79
0.8
0.81
0.82
0.83
0.84
0.85
0.86
0.87
0.88
0.89
0.9
0.91
0.92
0.93
0.94
0.95
0.96
0.98
0.99
1

 

 

and yes it has been identfied as measure

 

kpi.PNG

PFA , the pbix.

 

Kinldy advise

hi, @Anonymous 

Do you try the way I have post above, That should meet your requirement.

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

 

HI @v-lili6-msft 

I just checked your post,

I tryed by many ways;

But also it`s not working due to syntex errror:

 

KPI_UTIL = IF(ISBLANK([UTILIZATION_PERCNT])=FALSE(),UNICHAR(11044))))

KPI_UTIL = IF(ISBLANK('AGTPRF_FCT_PERFORMANCE'[UTILIZATION_PERCNT])=FALSE(),UNICHAR(11044))))

KPI_UTIL = IF(ISBLANK(AVERAGE('AGTPRF_FCT_PERFORMANCE'[UTILIZATION_PERCNT])=FALSE(),UNICHAR(11044))))

KPI_UTIL = IF(ISBLANK('AGTPRF_FCT_PERFORMANCE'[UTILIZATION_PERCNT]=FALSE(),UNICHAR(11044))))

KPI_UTIL = IF(ISBLANK(Value('AGTPRF_FCT_PERFORMANCE'[UTILIZATION_PERCNT])=FALSE(),UNICHAR(11044))))

kpi_null.PNG

 

 

hi, @Anonymous 

What is the column "Avg of UTIL%" in this matrix visual? Is not a measure? and what is your data structure?

If possible, please share a simple sample pbix file for us have a test. this will be a great help.

 

Best Regards,

Lin

 

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

I can`t attach file here any idea how

Hello @Anonymous 

You can post it to OneDrive or DropBox and share the link here.

Anonymous
Not applicable

HI, @Anonymous 

Just try this formula:

KPI_UTIL 2 = IF(ISBLANK(AVERAGE(AGTPRF_FCT_PERFORMANCE[UTILIZATION_PERCNT]))=FALSE(), UNICHAR(11044))

Result:

6.JPG

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Really appreciated @v-lili6-msft  🙂

 

Accept it as the solution

Anonymous
Not applicable

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.