Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Table visual not working if I add the value "duration"

Hello everybody,

 

 

I've created a table visual in PowerBI where machine-errors will be displayed.

But as soon as I add the value "duration" as a new column, the whole visual crashes (not displaying). 

Why can't I add the duration to my table? It's just adding a new column, which shouldn't be an issue. 

 

Data-type of "duration" in PowerBI = "time" as "*13:30:55 (Long Time)". 

In Dremio the fields are for example "00:05:20". So should be the same type.

 

I tried also in PowerBI to change the datatype to text for the "duration", didn't help.

 

Thanks for your help!

 

Greetings

8 REPLIES 8
v-jianboli-msft
Community Support
Community Support

Hi @Anonymous 

 

Could you tell me if your problem has been solved? If it is, kindly Accept it as the solution or share your solution with us. More people will benefit from it. Or if you are still confused about it, please provide me with more details about your table and your problem or share me with your pbix file after removing sensitive data.

 

Refer to:

How to provide sample data in the Power BI Forum

How to Get Your Question Answered Quickly

 

Best Regards,

Jianbo Li

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Bubble4502
Resolver III
Resolver III

Hi @Anonymous ,

 

Could you please provide me with more details about your table or share me with your pbix file after removing sensitive data.

 

Please refer to:

How to provide sample data in the Power BI Forum

How to Get Your Question Answered Quickly

 

Kind Regards,

Bubble

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Bubble4502
Resolver III
Resolver III

Hi @Anonymous ,

 

Does the table where "duration" comes from have relationship between the current table?

This condition usually caused by  no filter relationship between the field and the table

Here is an example:

Bubble4502_0-1660027989626.png

Bubble4502_2-1660028063815.png

 

Bubble4502_1-1660028018556.png

When you add "duration", the visual will meet some error:

Bubble4502_3-1660028178909.png

This will be fixed if relationship is created:

Bubble4502_4-1660028247882.png

Bubble4502_5-1660028265126.png

 

Kind Regards,

Bubble

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Hi @Bubble4502 

actually the duration is the last column of the same table. So there must not be a relationship, because it's integrated in the same table.

 

What could it be?

 

Greetings

v-jianboli-msft
Community Support
Community Support

Hi @Anonymous ,

 

Sorry for that the information you have provided is not making the problem clear to me. Can you please share more details to help us clarify your scenario?

For example:

Click See details and provide the error message.

vjianbolimsft_0-1659605595923.png

 

 

Please provide me with more details about your table and your problem or share me with your pbix file after removing sensitive data.

 

Please refer to:

How to provide sample data in the Power BI Forum

How to Get Your Question Answered Quickly

 

Best Regards,

Jianbo Li

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

@v-jianboli-msft : The error details are this:

 

"OLE DB or ODBC error: [Expression.Error] We couldn't fold the expression to the data source"

 

But this error is strange. Because if I put the duration as "earliest value", the data is showing up (but it's the wrong duration per line). If I put the duration as "not summarized" it should give the duration per each line correctly, but unfortunately the error is coming instead.

 

So what is the problem? Why does it not let me allow the "not summarized" values?

Anonymous
Not applicable

@amitchandak I just checked it. I had the duration on "not summarized". I changed to "earliest value" and also "latest value". Suddenly the table is showing up for both options, but the duration value is clearly wrong with both options.

 

So normally it needs to be "not summarized", but this one leads to that the visual is not showing up.

With "earliest" it is showing up, but with wrong durations.

 

What can I do?

amitchandak
Super User
Super User

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.