Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate II
Advocate II

Sync slicers not working in Power BI desktop - multiple issues - anybody having the same issues?

Hi all,


I am creating a report that I will be sharing via service... trying to use the new february feature for syncing slicers, but I have experienced a few issues (and I am wondering whether anyone else has experienced the same and if yes, did you manage to fix it?)


1) In my report where I used to navigate via pages using DRILLTHROUGH functionality (to drillthrough to a location and a client), I created a date slicer, location slicer and customer slicer and set it up so that they do not show, but sync across all my tabs (3 in total), so that I can have an intro page, where a consumer of my report can select date range, location and customer and once they do, this selection will be synced across my tabs.

Unfortunately using multiple slicers synced across multiple tabs does not seem to be working in this case (even if I removed the drillthrough filters from the individual pages). The whole report collapses and I am not able to see any content anymore even if I also remove the sync slicers functionality. This seems like a bug: looks like power bi desktop cached the settings of synced slicers and because I deleted the original slicers, even if I create new ones, no content is being filtered and I just see blank visuals...


2) So what I did next I closed the whole report and opened it again and tried to refresh the data, duplicatee the pages hoping that it would solve my problems... unfortunately with no luck.


Anyone facing the same issue like me? ANyone has an explanation or a suggestion for what I could try to make it work? Even if just let the drillthrough navigation working back again (as that does not work on this report anymore).


Thanks for any help.



Frequent Visitor

I have just solved the issue in my report. You need to ensure that you don't have any hidden slicers on your page. You can simply do that by opening Selection pane and review the list of available slicers. Then I removed all related to the slicer which seems to be problematic and then from Sync Sliders pane enable slicer again, and it worked.

Frequent Visitor

just wondering how did you all navigate through different page?


I have a main page, and add a button which will navigate accross different page. To navigate I added a bookmark to the corresponding page. 


I noticed when I navigate using the button that the filter doesn't carry over. However, when I click on the page tab manually the filter carries over.


the solution that works for me is to change the bookmark and remove 'data'


hope this helps.

Not applicable

Hi everyone, 


I had the same issue and we fixed it by modifying the cross-filter direction from Single to Both in the Data Model of the Report.

Check your relationships in the model. 

Hope it helps! 




Regular Visitor


1. Choose View in the top menu

2. Choose to check Sync slicers and Selection Pane

3. Within the Selection Pane, unhide all slicers. 

4. Move the slicers to the top within the Selection Pane and remove the slicers you don't need.

5. Refresh the page until your data is visible again.


Remember to check both Drillthrough filters and report, page and visualization filters.

Not applicable

I can only guess that we are syncing it incorrectly.  In the page with the slicer which in my case is page 1, I ticked everything and only unticked the visibility part of page 2 and everything synced accordingly.  If you hover your mouse to the first tick in page 1, it says add a copy of the slicer to the page and sync it.  This means except this is ticked, the slicer will not be synced in other pages.

Regular Visitor

@cllawrence  and I experienced something order to resolve our issues we turned on the edit interactions, have the Selection and Sync Slicers panes visible - then you select the "bad" slicer in the Sync Slicers pane, and turn the interaction to none for each visualization. We think that under File > Option/Settings > Options > Current File > Query Reduction and checking the box for Disabling cross highlighting/filtering by default will eliminate this problem from happening as you will need to turn on any interactions you need. It would be nice if the option was there to remove the "bad" slicer from the Sync Slicers pane.

New Member

Amazingly after a year now this problem still exists. Rebuilding the pages and reconnecting/loading the data connections works until you change something in your report... then it all breaks again.

New Member

I found that my scenario seems to be due to re-sizing my pages and the hidden slicer was outside of the new page dimensions (16:9).   When I enabled view for the slicer to troubleshoot it I couldn't find it on the pages that it wasn't working on.

I did the following to resolve this issue:

1. Re-sized my pages back to previous larger format

2. Removed all of the slicers showing this issue (not syncing properly)

3. Re-sized my pages back to where I want them (16:9)

4. Added the slicer I need back and sync'd, hid it as needed.


Test, test, test!

Fixed and works as intended!   (WHEW)

Not applicable

Does anyone know if this is still an issue?  I think I experienced the same this morning. 

We are still experiencing these issues. Also with the latest september release, which by the way has some other weird issues, such as PBIX files that won't refresh anymore. And those issues also reflect to the Power BI service.


Microsoft, please address these issues!





Not applicable

It still occurs.  I am not sure it is an issue or not.  Kind of a bi-product of syncing or not syncing slicers.  See my comment on the string above and you will see the issue pretty clearly and be able to resolve.  Once you see the view of slicers you can see how this occurs and how to fix.

New Member

I'm seeing the same problem as well.  Really frustrating.

Not applicable

I found the solution to my problem somewhat by accident.  If you go to the View tab and click on "Selection Pane".  THis will show you all the controls that are on the report.  It looks like what happens when you sync the slicers it can put a number of your slicers on the page but not make them visible.  Thus they will filter things out without you realizing what is going on.  From what I can tell there are two indicators possible for a report component a "dash" which appears to mean invisible and a "eyeball" which means visible.  If you make the invisible components visible you will find that there are a number of slicers that need to be deleted from your report and all the totals will work correctly then.  You may need to review the Sync selection pane to make sure all the slicers you have are synced correctly.

Thank you, thank you, thank you. This has been doing my head in for the last couple of days. I just couldn't understand or work out the sync slicers at all. As you say - I had a number of hidden slicers which I did not know about. Using the selection pane, I made them unhidden and deleted the ones I did not want. Everything works fine now. This needs to be addressed.

Thanks a lot Tnohelty - you saved my day! I was stragling with this several hours. Have to agree - very frustrating!

Advocate III
Advocate III

I have to confirm that this issue still exists in the May release of PowerBI Desktop!


My report has 8 pages and on the first page I  select 2 different forecast runs (out of 30) that I want to compare with each other. So I made 2 tables 'Current' and 'Previous' each with all the 30 available RunID's, used those as input for 2 slicers and synced them over the whole report.


At some stage - probably after adding a new page and trying to sync that one too - the 'Current' slicer stopped working. I added table visuals to the different pages to inspect the 'Current' data table and got either all 30 RunID's or nothing ('blank') or some previously selected value. So more or less every page had a different selection stored from that synced slicer but I wasn't able to change that.


WORKAROUND: I made 2 new tables with different names 'Current Run' and 'Previous Run', used those as input to 2 new selection slicers on a new first page, synced them over the whole report and everything was working again. 

Obviously I'll be very careful with adding new things to the report since the 'slicer syncing' still has this bug that will hopefully be acknowledged and fixed by the developers soon.

I had a similar problem though was only able to replicate it in Chrome.  A simple cache refresh (<CTRL><F5>) resolved my issue though I wouldn't be surprised to see it raise it's ugly head again.

I have the same problem, is there someone who is looking into this weired behaviour?

Not applicable

I am seeing the same problem.  

Advocate I
Advocate I

Hi all,


I was finally able to fix my issue. There is no apparent logic in how it was resolved. I just accidentally came across this solution which worked after trying a number of other steps. Here are the steps that I tried that DIDN'T work (just for information):

* un-sync all slicers

* create new page and copy visuals from an old tab to this new page

* delete some of slicers and re-place them by newly created slicers

* change ranges/options on slicers (in my case some of the slicers didn't show any availbale options)

* re-fresh report

* close/open report

* open report on another laptop


What DID work after all was a single slicer that I removed. After trying all of the steps above I decided to completely recreate the report by building all visuals from scratch on new pages . And at that time I noticed that if I add a particular slicer (in my case it was a Date Range slicer) to that new page, then everything would stop working on that new page. After that I went back to old all tabs and removed this slicer from all of them. This immediately resolved all of my issues.


The moral of the story is that SYNC Slicer option does some funky things under the hood so that it alters relationships between all slicers and visuals in a way that cannot be fixed by undoing the sync. To fix it you'll need to find that offending slicer and remove it completely. If the number of slicers in your report is small, then I would suggest to remove all of them and then re-create them, it is still simpler then re-doing visuals.       

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.