Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
stanbeamish
Frequent Visitor

SandDance background image

Hi community,

 

I am trying to set the background image on the SandDance (version 4.0.0) visual (Power BI Desktop, and also Power BI Service).

The image is of type PNG.

stanbeamish_1-1668431207678.png

XCoord and YCoord are of type Integer (tried with decimal also), but the fields below the dropdown to set min and max on the axis do not show, nor does the background image is displayed.

Am I missing something? Any help very welcome.

1 ACCEPTED SOLUTION
stanbeamish
Frequent Visitor

Hi myself 😁

 

but it maybe useful to others struggling too.

 

There has not been a problem to the column types, as these were already numeric, but as it is now working, I list what I did (Scatter Layout as seen in the screenshot above):

 

  • the Z Axis contains the numeric count value that relates to the displayed data points
  • the image is a jpeg with a (white) background (the png used before was transparent resulting in a "black" image on which the actual image parts were nearly invisible)
  • I twice had to delete the visual and recreated it in the report - resulting in a working visual
  • it seem that in Settings of the visual, Show legend can be set to Off, while Show axes is On (not sure if this really takes any effect)

 

So finally, I am able to make use of the fantastic SandDance visual. Thanks to the developers!

If I have other findings, I will edit this post

View solution in original post

3 REPLIES 3
stanbeamish
Frequent Visitor

Hi myself 😁

 

but it maybe useful to others struggling too.

 

There has not been a problem to the column types, as these were already numeric, but as it is now working, I list what I did (Scatter Layout as seen in the screenshot above):

 

  • the Z Axis contains the numeric count value that relates to the displayed data points
  • the image is a jpeg with a (white) background (the png used before was transparent resulting in a "black" image on which the actual image parts were nearly invisible)
  • I twice had to delete the visual and recreated it in the report - resulting in a working visual
  • it seem that in Settings of the visual, Show legend can be set to Off, while Show axes is On (not sure if this really takes any effect)

 

So finally, I am able to make use of the fantastic SandDance visual. Thanks to the developers!

If I have other findings, I will edit this post

stanbeamish
Frequent Visitor

Hi @v-stephen-msft ,

 

thank you for your message, but unfortunately the chart is already a Scatterplot and the columns are already of numeric type. The dialog to add a message already said so in the help text, so that was the first to check. 

 

But the columns are not detected as numeric, although these clearly are. Maybe there is something else that I missed or the feature does not work as expected?

 

Best Regards

 

 

v-stephen-msft
Community Support
Community Support

Hi @stanbeamish ,

 

Please meet the following requirements and try again.

Background image can only be shown on Scatterplot, Density and Stacks charts. And columns must be numeric type.

vstephenmsft_0-1668493471368.png

 

Best Regards,

Stephen Tao

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors