Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
djbc1986
Frequent Visitor

Power BI changes integer numbers to decimal from an Excel file.

Hi there


I'm kind of new with this tool, and right now I've got this doubt with some numbers that changed into decimals from an excel file.

 

When I open the excel, I see all the number as integers. However, when I upload the file into PowerBI, all of them are represented as decimals.

image.png

 

image.png

 

So, I wonder if I have to change any regional configuration or something else. I found that changing any column to text type and then deleting the comma I'm reaching the result that I need, but I have too many columns that will require this action, and this is taking to much time.

 

Regards,

1 ACCEPTED SOLUTION
tex628
Community Champion
Community Champion

Check the regional settings in PBI desktop and language settings on your PC. There might also be regional settings in excel. Make sure that they are all in sync. 

/ J


Connect on LinkedIn

View solution in original post

7 REPLIES 7
Anonymous
Not applicable

Hi @djbc1986  ,

 

Have you tried changing the type of your columns in Power BI Query Editor from Decimal to Whole Number?

>Home > Edit Queries
>Select all columns that need Type Change
> Transform
> Data Type: Whole Number

Let me know if that helped.

Cheers,
Robin

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @Anonymous 

 

Yes I have. I tried with some columns but I was getting wrong numbers. For example, on the first register before making the change I was watching 5,762, but after that I've got 6.

 

image.png

 

That is why I wonder if maybe I have to modify something with my regional configuration.

 

Regards,

tex628
Community Champion
Community Champion

Go into the query and remove the step that converts them to decimal in the beginning. Instead try formatting them to text, and then into integers as a new step.


Connect on LinkedIn
tex628
Community Champion
Community Champion

Could work as a temp fix.. Honestly I'm not sure what could cause this but my guess would be on regional settings aswell!


Connect on LinkedIn

Hi @tex628 

 

Thanks for your replay. I did something like that. However, I have a large number of columns, and I was trying to avoid to modify each one of them.

Hi @djbc1986 ,

I think the reply of tex628 should be helpful.

Have you solved your problem?

If you have solved, please always accept the replies making sense as solution to your question so that people who may have the same question can get the solution directly.

If you still need help, please share some data sample so that we could copy and test on it.

In addition, please check if you have installed the latest version of power bi desktop.

Best  Regards,

Cherry

 

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
tex628
Community Champion
Community Champion

Check the regional settings in PBI desktop and language settings on your PC. There might also be regional settings in excel. Make sure that they are all in sync. 

/ J


Connect on LinkedIn

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors