Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate II
Advocate II

PBI Desktop Query Editor - can't drag queries to reposition them

This seems to have stopped working with October update.

In the query list (left hand pane) of the Query Editor window I can no longer drag queries to new position on the list.

The only option now is to right click and use Move Up, Move Down.

This makes it frustratingly slow to do the simple task of reorganising my queries.

Microsoft Employee
Microsoft Employee



Please try with the latest version 2.52.4921.461 (November 2017) of PBI Desktop. I can drag the query properly as following gif.


PBI Desktop Query Editor - can't drag queries to reposition them.gif



Best Regards,

View solution in original post

Frequent Visitor

I have noticed different behavior if it is store or exe download file. For me store doesn't work, exe it works. How weird.

Yeah, I stopped using the store version months ago because of this bug.
Not applicable

what is the alternative from downloading the store version? I can only find the store version on google.

Not applicable

@jeffshieldsdev - the download link off that site launches MS Store. Thanks for your help btw!

Not applicable

Thanks. I think my IT group restricts us from downloading outside the MS Store. 

Not applicable

you the you the bestttt.....better than the rest

Solution Sage
Solution Sage

I'm unable to rearrange queries in the Query Editor in the April 2019, Microsoft Store-version.

Confirmed this is still a problem as of the current release on Oct 1, 2019.

Advocate IV
Advocate IV

@nelsong20 would it be possible to take this off being solved. It is certainly still an issue.

I just checked this again now that I have installed the April 2018 update and it seems it is, in fact, broken again.


I can no longer drag queries in the query list. And, as well, I cannot drag steps within a query.


(dcresp >> I don't know how to take it off being "solved". I had thought the community administrator did that. However I tried flagging it as a new issue. Hope that helps to get it recognised).

Yes this is certainly not solved.

Not only is it not solved but, from my perspective, it WAS solved but then BROKEN again.

Helper I
Helper I

This issue seems to have reared its head again. Neither can I click/drag applied steps up and down within the Query Editor.

hi mikegunns,


I am not experiencing the problem at this time, but I am running on an earlier release (12th Jan). The PBIDesktop released later in January (I think about 20th Jan) caused other problems for me ( 

 So I have reverted to the earlier release - and the click/drag is working for me.

I have been getting this issue for a while. I am using the March version. I am wondering if it has anything to do with using an MS Surface. Are others still getting this?

I am running the March 2018 release on a Surface Pro 3.

Just checked and it still seems to be working ok for me.

I'm now on the March 2018 release and still cannot click/drag queries nor click/drag to reorder applied steps.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.