Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Helper I
Helper I

Need help with R script



I have two tables in my report. In query editor I have merged them and then I want to save the result to a text file.


I have tried to add this script to the query Itemlist:

write.table(trim(dataset), file="C:/Users/KLJ/Documents/Power BI/Test10.txt", sep = "\t", row.names = FALSE, append = TRUE)


but I get this message:


(Sorry for the bad picture)


Is there a R script that can save this query to a text file?

R scrips is very new to me. 


Here is a link to a copy of the pbix file


Thanks in advance.


Best regards 


Memorable Member
Memorable Member

I've used R to export data a few times from both ther editor and the visuals


This R script works for me.


# 'dataset' holds the input data for this script

write.table(dataset, file="C:\\temp\\Test.txt", sep = "\t", row.names = FALSE, append = TRUE)

output <- dataset

The M for my test looks like this.


    Source = Table.NestedJoin(Table2,{"Column1"},Table2,{"Column1"},"Table2",JoinKind.LeftOuter),
    #"Expanded Table2" = Table.ExpandTableColumn(Source, "Table2", {"Column2", "Column3"}, {"Table2.Column2", "Table2.Column3"}),
    #"Run R Script" = R.Execute("# 'dataset' holds the input data for this script#(lf)#(lf)write.table(dataset, file=""C:\\temp\\Test.txt"", sep = ""\t"", row.names = FALSE, append = TRUE)#(lf)#(lf)output <- dataset",[dataset=#"Expanded Table2"]),
    #"""output""" = #"Run R Script"{[Name="output"]}[Value]

Trim in r doesn't work on a dataframe. So if you need to trim either do it before you export in M or use sapply functions in r.

M is easiest, but the R option might be quicker with very large datasets.

Hi stretcharm


I've tried your proposal but I still get the same error message.





I rebuild the query according to @KenPuls blog but still got the error.

Then I changed the the Privacy for the file to Ignore the privacy levels and it worked.

I not sure that is the right way to do this but ontil there is another solution this most do it for now.


Thank for your help @stretcharm

So turning off Privacy does a couple of things:

  • It will ignore the error
  • It will (most likely) speed up performance

The issue is that it no longer checks to make sure the data sources are safe to combine without leaking data.  If all my data is in the organization, I usually turn this setting off, but you do want to be careful of just doing that as a blanket answer.

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors
Users online (1,257)