Showing results for 
Search instead for 
Did you mean: 
New Member

MySQL Connector Not Working

Hi All,


I'm having a very similar issue to what was detailed here 

Only that was 5 years ago with much older versions of everything.


I'm trying to get setup on a new machine and am unable to initiate a conneciton to MySQL.


Power BI Desktop: Version: 2.104.941.0 64-bit (April 2022)


I've installed:

mysql-connector-net-8.0.29.msi   (seems there's only a 32bit version available for this)




and keep getting the error below when trying to add a MySQL data source (before even entering any specific server info):daverothwell_0-1651186844952.png



I have MySQL Workbench and am able to connect to my target server with no issue. I tried uninstalling the 64bit version of the desktop app and using 32bit instead but it didn't make a difference.


Is there something else I'm missing??


Any suggestions much appreciated!!


Not applicable

I installed MySQL server v8.0.16 and connector v8.0.16 and it worked. I guess it is worth trying. Good luck! 

View solution in original post

New Member

So I tried everything and finally it worked.


1) Remove everything related to power bi and mysql/connector using control panel

2) Go to registry editor-Software-WOW6432Node and remove MySQL, MYSQL  AB
3) Go to registry editor-Software remove ODBC
4) Go to registry editor-Software remove MySQL AB
5) Locate MySQL folder and remove all its contents (if exist)
6) Remove cache data from %LocalAppData%\Microsoft\Power BI Desktop

7) now restart computer. Install 8.016 server and ODBC and NET connector for your arcchitecture
😎 restart computer. Install Power bi desktop

Hopefully helps

New Member

I tried everything. This is ridiculous.

I end up with seting up data pipiline with a python connector connecting to the mysql database and retreiving data as csv file

then I will connect that csv file to the power bi...

Thanks Microsoft 👍

New Member

currently 8.0.31 is only working. Latest version is not working for POWER BI. 

Trust me. This will save you a ton of time. 

Solution Sage
Solution Sage

Version 8.0.32 (latest as of this writing) worked for me, whereas all previous menioned here did not. Go figure

Regular Visitor

Just yous version mysql both 8.0.16 





Helper I
Helper I

UPDATE: I went to install MySQL Community on a fresh device and the dialogue box came up with a mandatory upgrade : Connector/NET 8.0.31 (Upgrading Connector/NET 8.0.16)  - see attached. So maybe this is a fix from MS/Oracle? it would be nice to know so that we can all use the latest version - MS/Oracle are you there? can you respond?

Frequent Visitor

Why the hell does MS keep developing software like this for decades?

New Member

Hey I'm on Windows 11. I had the same issue with MySQL Connector Net 8.0.29. My fix was uninstall MySQL Connector Net 8.0.29. Then I installed an older version. MySQL Connector Net 8.0.23 to be specific. Seems like bug with version 8.0.29. On the download page click Archives tab to try an older version.

Not applicable

I installed MySQL server v8.0.16 and connector v8.0.16 and it worked. I guess it is worth trying. Good luck! 

Thank you! This worked for me. Kind of unbelievable that newer versions of the connector fail at their main reason for existing.

@Anonymous Could you please pass me the link of what you just installed? Thank you

try this:


Otherwise just go to the main page ( and click on Archives at the top and you can search for the older version.

Thank you.


I installed 8.0.32 and it's working for me.

Not applicable

The 8.0.16 version worked like a charm for me.

@daverothwell I installed MySQL Connector version 8.0.16 that you reccommended


Anyhow, I am not sure what caused a trigger of this software keep changing back to newer version of 8.0.29 by itself, without me uninstall the older version of 8.0.16


Do you or other users experience this same issue? Please advise.

Thank you daverrothwell. This older version works for me.

Frequent Visitor

I have the same issue since yesterday. I got MySQL Connector Net 8.0.29 installed but I still cannot connect in Power BI. Do you still experience the same issue today?

Not sure if this will help, but it worked for me.
After installing the connector, I still got an error when trying to choose "MySQL" as the data source. Instead choosing "ODBC" (the connector itself? I don't know) is what worked as expected.

I'm having the same issue, I tried down-grading to v. 8.0.18 but still get the same error - anyone got a fix?


I had this issue in May and I tried download different verison of MySQL but there's nothing work until someone suggested about version 8.0.16 and it works

Helpful resources

May 2023 update

Power BI May 2023 Update

Find out more about the May 2023 update.

Submit your Data Story

Data Stories Gallery

Share your Data Story with the Community in the Data Stories Gallery.

Top Solution Authors