Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Frequent Visitor

Missing rows in table view


I run into a strange issue. My report is showing incomplete data. I checked my queries and I found out that I miss certain rows in table view, while these rows are visible in query editor after running the queries. Queries are running without any notifications/warnings/errors, table seems complete in query editor but seems to lose records when loading to table view. Does anyone know how to solve this issue?

Regards, Theo

Frequent Visitor

I had the same issue and what worked for me was to go to each field that had numeric data, in the Visualisations pane, and make sure they are set to Don't Summarize and then Show Items with No Data. 



Frequent Visitor

I am having the same issue, the table visual has no filters but is leaving out rows. The table in power query has complete data. The table visual is very simple, I am not able to find out a cause for these missing rows. 

New Member

highlight all columns in power query. go to transform, trim and then clean.

Resident Rockstar
Resident Rockstar

Just to double check, have you refreshed the data preview in the Query Editor recently?  Just wanting to check that the data you're looking for is still in the data source itself.


If it's there, but not showing up in Table view, be sure to right click the top of the column and clear all filters.  I know that I've definitely gone crazy trying to find a specific entry, but was unable to find it because I had forgotten an old filter from a few hours ago.


If it STILL doesn't show up, try filtering in ONLY the missing data from the Query Editor and see if it shows up in your visuals.  It would also be helpful if you could recreate a subsection of the data and share the .pbix with us.

Hello @tarunsingla @Cmcmahan 


I refreshed data and checked that no filters are active in table view. In my query I added a filter to just filter the missing records. In query editor the missing rows are visible, but they are not visible in table view and therefore also missing in my report. Seems like a bug in Power BI to me. See screenshot which shows the same table in query editor and in table view. Table in table view is empty.


Regards Theo 


At the top of the Query Editor, you've got a bar that tells you that the data preview is 108 days old, and may be out of sync. 


Hit the refresh button, and it should fix your discrepancy.

Solution Sage
Solution Sage

There's probably a filter on your report page that is filtering out some records.

To confirm, go to View tab and check the Selection Pane box. Under the Selection Pane, see if there are any undesired filters on your page.


Also, check for any report level or page level filters in your pbix.





Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors