Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
eWise
Advocate I
Advocate I

Map Visual working in one file and not in in an another similar file

I have one file where my map visualization just wont work but is working on another. All seetings are the same.

 

My biggest issue is that I have an on going project on the file where it's not working and I can't just start from scratch.

 

If I start a new project through the file which is not working, the visualization doesn't work.

 

If I open a new file outisde the project am working on, the visualiaztion works ok. Am at a loss on what could be the problem.

 

The >>Use Map and Filled Map visuals>> is already turned on.

 

 

Non working file

eWise_0-1662560539754.png

 

 

working file 

 

eWise_1-1662560615677.png

 

 

 

Thanks everyone.

1 ACCEPTED SOLUTION
v-mengzhu-msft
Community Support
Community Support

Hi @eWise ,

 

There are something different between two Map visuals, as you see in the following image, their title are different, which means data you applied are also different. 

vmengzhumsft_0-1662621658464.png

vmengzhumsft_2-1662621759425.png

Try to keep it same as each other to see if it can work.

At the same time , there are some reasons that may cause this situation, like relationships you created to other tables but with unmatched records.

 

Hope the following links can help you:

Solved: Blanks appearing in visuals - Microsoft Power BI Community

Problem with Power BI showing blank visuals : PowerBI (reddit.com)

 

Best regards,

Community Support Team Selina zhu

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

View solution in original post

2 REPLIES 2
v-mengzhu-msft
Community Support
Community Support

Hi @eWise ,

 

There are something different between two Map visuals, as you see in the following image, their title are different, which means data you applied are also different. 

vmengzhumsft_0-1662621658464.png

vmengzhumsft_2-1662621759425.png

Try to keep it same as each other to see if it can work.

At the same time , there are some reasons that may cause this situation, like relationships you created to other tables but with unmatched records.

 

Hope the following links can help you:

Solved: Blanks appearing in visuals - Microsoft Power BI Community

Problem with Power BI showing blank visuals : PowerBI (reddit.com)

 

Best regards,

Community Support Team Selina zhu

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Thanks @v-mengzhu-msft for your suggestions. I actually just restarted my Power BI and it started working. Am sure the resources you provided will come in handy.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors