Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Kfausch
Helper II
Helper II

Failed Refresh Using ODATA Web Services

Hello,

 

I just encountered an error when refreshing my report that is using ODATA connections. This report has been working and I have not recently made any changes. 

 

"DataSource.Error: OData: Request failed: The remote server returned an error: (400) Bad Request. (Cannot process the request because the default company cannot be found. You can specify a default company in the service configuration file, or specify one for each tenant, or you can add a query string in the form of "company=[name]". You can see the available companies by accessing the default OData web service, Company. For more information, see "OData Web Services" in Help.)"

 

I cannot find where the error is trying to point me. Is anyone fimilar with this problem?

 

Thanks,

Kevin

 

1 ACCEPTED SOLUTION

Hi @Kfausch ,

 

looks like a Business Central / Dynamics NAV OData service.

Could the Service Tier have been updated?

 

You (your IT) have to specify a default company in the Service Tier configuration file, or you have to add a query string in the form of "company=[name]" to your query. 

 

Regards,

Marcus

Dortmund - Germany
If I answered your question, please mark my post as solution, this will also help others.
Please give Kudos for support.

Did I answer your question?
Please mark my post as solution, this will also help others.
Please give Kudos for support.

Marcus Wegener works as Full Stack Power BI Engineer at BI or DIE.
His mission is clear: "Get the most out of data, with Power BI."
twitter - LinkedIn - YouTube - website - podcast


View solution in original post

2 REPLIES 2

Hi @Kfausch ,

 

looks like a Business Central / Dynamics NAV OData service.

Could the Service Tier have been updated?

 

You (your IT) have to specify a default company in the Service Tier configuration file, or you have to add a query string in the form of "company=[name]" to your query. 

 

Regards,

Marcus

Dortmund - Germany
If I answered your question, please mark my post as solution, this will also help others.
Please give Kudos for support.

Did I answer your question?
Please mark my post as solution, this will also help others.
Please give Kudos for support.

Marcus Wegener works as Full Stack Power BI Engineer at BI or DIE.
His mission is clear: "Get the most out of data, with Power BI."
twitter - LinkedIn - YouTube - website - podcast


Hi Marcus,

 

Our server is hosted by our Nav trading partner, but I can check with them to see if thats the case. Thank you for the suggestion! I will update if a fix is found.


Thanks,
Kevin

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors