Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
vitexo87
Post Prodigy
Post Prodigy

Error while updating data

the following error occurs when updating data:

 

"The base version should not be negative when the impact is required for a transaction"

 

what should I do?

9 REPLIES 9
gguarnaschelli
New Member

Same is happening to me. I have been using the same tables for a while, and it was only a month ago that this started happening, without any changes to the data... 

Need help with this please.-

dorofema
Regular Visitor

Hi, 

 

I have the same trouble after I get one more table from mysql database. I have tried to load tables different ways in different order. If I get data from this table firstly, it seems OK. All another ways cause the same issue. What is wrong in this table? 

Anonymous
Not applicable

Problem just "popped up" for me.  Made a copy of a pbix file for additional testing/development, added connections to 2 additional dimension tables (Excel) and C R A S H!

 

This issue needs a response - please.

kalieberman
Regular Visitor

I am getting this error -- I duplicated a data source and changed some filters - I am going to try to recreate the whole new data source definition - must me something in the copy?

 

Version: 2.59.5135.781 64-bit (June 2018)

Anonymous
Not applicable

Hello,

 

I face the same issue and really don't understand what happen as everything looks normal in my way of working.

 

Any clue from Microsoft ?

trevor
Helper I
Helper I

I get the same error with an ODBC query.  It was working fine and all I did was add in 2 extra columns and exclude one record that caused a duplicate.

Why does this happen - what does the error actually mean?

ag_tiny
Frequent Visitor

I had the same error.

My data source is in Excel.

I removed the filter in Excel and re-did Get data in PowerBI.

It worked!

 

jessem
Frequent Visitor

Also having this issue.

 

Created a blank query for one of my MailChimp lists, imported JSON, converted to table, shaped the data, then duplicated that table and changed all of the values to reflect another list I have. It worked with the one table but as soon as I duplicated it, they're not working. I obviously did something wrong. 

Are you still getting this error? Where is it showing up? Can you share the query that generates this error (edit queries -> advanced editor -> select all, copy and paste)

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.