Forum Discussion

jpd99's avatar
jpd99
Frequent Visitor
6 years ago
Solved

Direct Query Errors usign PostgreSQL

I have been trying in vain for days to create a direct query report drawing from a postgresql database now that this is supposedly supported.  Upon closing and re-opening an otherwise functioning report I get an error message: 'Couldn't load the data for this visual' across all visuals.

 

'Direct query may not be used with this data source - consider moving to a supported data source or upgrading the SQL server data source to the latest available version.'

 

I can't understand the failure since on saving the report worked ok.  It's extremely lim

2 Replies

  • I encountered the same issue and I found a work around.

     

    I installed a gateway and configured it to point to that postgres instance server, this acted sort of like a help for the data source to find a route and authenticate without encryption. However i observed that the direct query could now connect and if I changed data and refreshed on the dashboard, i would see the changes.

     

    The only draw back was the gateway needs to be up, but the direct query works just fine

     

    would love to hear from someone how many rules I have broken or any better option.