Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
pabloreadi
Regular Visitor

Connector Postgre SQL DATABASE

Hi,

I want to get data from a PostgreSQL database but the error appear "This connector requires one or more additional components to be installed before it can be used". I installed Npgsql-3.2.4.msi , I restart computer but the same error. Help me please.

1 ACCEPTED SOLUTION


@pabloreadi,

It seems that your PostgreSQL is secured with SSL. To make Power BI Desktop work with secured PostgreSQL, you would need to copy SSL certificate for the PostgreSQL server to the machine running Power BI Desktop and import it to Windows certificate store. Because Power BI Desktop uses the windows certificate store to decide what to trust, once you tell the Windows that is running Power BI Desktop to trust the SSL certificate for the PostgreSQL server, Power BI Desktop will trust it too.

In addition, in the configuration folder for the PostgreSQL server there is a postgresql.conf file, search it for SSL settings, there is one with the location of the SSL certificate. Take a look at the server name when you import the SSL certificate and connect from Power BI Desktop using the same server name. Then check if the above error goes away.

There is a similar thread for your reference.
http://community.powerbi.com/t5/Integrations-with-Files-and/Postgres-error-with-Power-BI-Desktop/td-...



Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

25 REPLIES 25
nmsivasankar
Advocate II
Advocate II

I am experiencing a similar problem with connecting to Postgres, Error "This connector requires one or more additional components to be installed before it can be used" appears while trying to setup a connection to Postgres. Error continues even after installing the Npgsql-4.0.3.. I am still able to connect using ODBC but i do not prefer to use the ODBC.

 

Any one managed to make this working ? 

Anonymous
Not applicable

Same issue.  New to this product and this is very disappointing.

Anonymous
Not applicable

How about fixing this?   How about supporting things beyond Microsoft?

 

Very disappointing that an enterprise still can't use PowerBI effectively because of problem with PowerBI data connectors (or lack there of, or lack there of native support...)   Very dissappointing. 

 

Apparently Google's Looker product is the way to go with this non-sense, no-reponse from MS.  They provide more native support for various database and is response to customer needs.  Unfornuately, MS is up to it's NIH (Not Invented Here) attitude.  Again very disappointing.

Same issue.

 

I installed Npgsql via

 

 

Register-PackageSource -Name nuget.org -Location https://www.nuget.org/api/v2 -ProviderName NuGet
Install-Package Npgsql -Verbose

Restarted system, without effects. I still get the error "this connector requires one or more additional components to be installed before it can be used", just after choosing PostgreSQL data type.

 

With odbc works without problems but can I update PowerBI Service via Power BI Gateway using ODBC?

 

"First they ignore you. Then they laugh at you. Then they fight you. Then you win." - Mohandas Gandhi.

Hi, am still using the odbc conectar, i was talking with PowerBi support but they cant gave me any solution. Is not the best with odbc  but for now i think is the one.

Thanks for your response, Sad to know that MS was not able to offer you the solution.

Anonymous
Not applicable

Actually, after installing Npgsql 4.0.0 and restart the power BI desktop, I can get the Postgres DB login screen to pop up, but when trying to connect, I get the following error:

 

powerbi-postgres-connection-error.png

Anonymous
Not applicable

Hi there,

 

This popup happens to me even after I installed Npgsql-4.0.0.msi. The solution link didn't show how to get past the popup?

 

 

Personally, I wouldnt use the PostGRE SQL connector. I would create a custom ODBC connection using the typical connection protocols for PostGRE SQL, and then simply use the ODBC connection method within PowerBI to connect to your data source. This bypasses the PostGRE SQL errors. 

Anonymous
Not applicable

Hi there,

 

This popup happens to me even after I installed Npgsql-4.0.0.msi. The solution link didn't show how to get past the popup?

 

 

copytac
Frequent Visitor

All,

 

This seems like a poor solution in my opinion. I can connect via odbc directly to the data source, with PostgreSQL driver installed, without the need for this certificate issue.

 

Simply create a system DSN in your 64 ODBC driver with the proper connection information. Once your system DSN is setup correctly, you can use the ODBC connector in power bi to connect to the data source using the system DSN.

 

Much more straightforward.

 

It doesnt make sense that my access application can access my PostgreSQL server, but PowerBI cant? Seems like a cop out to me,

Thanks for this information, work for me!! in addition i want to do a question, i try this connection with a encrypted password and power bi said that the authentication failed, but if i try with decrypted password its work. Have u any idea, why this ?

I am having a hard time creating a New Data Source to SQL Server? any tips there?

 

Whether I try connecting with Windows NT or with SQL server authentication I get the following error message:

 

---------------------------
Microsoft SQL Server Login
---------------------------
Connection failed:
SQLState: '01000'
SQL Server Error: 53
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
Connection failed:
SQLState: '08001'
SQL Server Error: 17
[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.

---------------------------
OK
---------------------------

 

 

Thanks

I'd recommend starting new thread. Rather than tacking onto someone else's question, which isn't direcly related to your issue.

 

At any rate, you should give more info.

Specify what SQL Server (MS SQL version, is it Express?) you are trying to connect to.

If you are using alias for the connection? Try using IP address suffixed by port# to test.

Are you able to connect to it using SQL Management Studio remotely? etc etc.

v-yuezhe-msft
Employee
Employee

@pabloreadi,

In my environment, I installed Npgsql 3.1.7 and I selected the option to install to the GAC during the installation process, there is no issues when I connect to PostgreSQL in Power BI Desktop.

In your scenario, please ensure that you select the option to install to the GAC when installing Npgsql 3.2.4. And you can also try to install 3.1.7, then check if the connection is successful.



Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-yuezhe-msft This solution works! Thank you

Could you add the information about the GAC for NPGSQL into the prerequisites https://docs.microsoft.com/en-us/power-bi/desktop-data-source-prerequisites ?

@v-yuezhe-msft thanks for your answer, when I installed Npgsql 3.2.4 I selected the option to install to the GAC, well i uninstall this version and install Npgsql 3.1.7, and I advance one step but now the error is the following:

 

DataSource.Error: TlsClientStream.ClientAlertException: CertificateUnknown: Server certificate was not accepted. Chain status: A certificate chain could not be built to a trusted root authority. . at TlsClientStream.TlsClientStream.ParseCertificateMessage(Byte[] buf, Int32& pos) at TlsClientStream.TlsClientStream.TraverseHandshakeMessages() at TlsClientStream.TlsClientStream.GetInitialHandshakeMessages(Boolean allowApplicationData) at TlsClientStream.TlsClientStream.PerformInitialHandshake(String hostName, X509CertificateCollection clientCertificates, RemoteCertificateValidationCallback remoteCertificateValidationCallback, Boolean checkCertificateRevocation) Details: DataSourceKind=PostgreSQL

 

I'am looking for the solution, but I cannot understand about the security and certificates.


@pabloreadi,

It seems that your PostgreSQL is secured with SSL. To make Power BI Desktop work with secured PostgreSQL, you would need to copy SSL certificate for the PostgreSQL server to the machine running Power BI Desktop and import it to Windows certificate store. Because Power BI Desktop uses the windows certificate store to decide what to trust, once you tell the Windows that is running Power BI Desktop to trust the SSL certificate for the PostgreSQL server, Power BI Desktop will trust it too.

In addition, in the configuration folder for the PostgreSQL server there is a postgresql.conf file, search it for SSL settings, there is one with the location of the SSL certificate. Take a look at the server name when you import the SSL certificate and connect from Power BI Desktop using the same server name. Then check if the above error goes away.

There is a similar thread for your reference.
http://community.powerbi.com/t5/Integrations-with-Files-and/Postgres-error-with-Power-BI-Desktop/td-...



Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.