Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Daryl_K
Resolver II
Resolver II

Any way to "force" y-axis scale sync or match on a combo chart?

So I notice if you make a stacked column / line chart by default the y-axis scale is totally different between the columns and the lines. This can be very confusing - especially when they are the same metrics (one is weekly or monthly while the others are a trend, maybe a goal line, etc.)

 

If you turn on "show secondary" and enable zoom slides you at least have an indication of the differnet scales, and can manually fiddle with the sliders to try and get them close to same scale, but it's far from exact.

 

Lastly, I discovered that if you go to "Y-axis (Line)" and for the End value select the values used for the columns it automatically brings the line y-axis close(er) to the column y-axis, but it's not really the same scale and in some cases is even further off.

 

Is there a way to actually sync these two scales, and if not, why isn't there? For combo charts that have discreet (column)_ and trends of the same data the option to enable y-axis sync or lock should be mandatory!

7 REPLIES 7
AlexisOlson
Super User
Super User

Can you not just turn off the secondary axis entirely? If there is no secondary axis, they'd have to be on the same scale (make sure to clear any values you may have in the Range).

From what I can tell, turning off "show secondary" only hides/removes the secondary y-axis legend (scale). It doesn't change the actual scale of the y-axis the lines are in, it's just not obvious that they're on two different scales because you don't have the second legend to show how far off they are. Of course if you know the data, it's still pretty clear though...

I have seen that behavior too but it's not completely consistent. Humor me and try Reverting to default the Secondary y-axis and then try toggling it on and off a couple of times to see if it changes to what you want.

Do you mean just toggle the "show secondary" on and off a few times? If so, no change.

 

If I misunderstood you please clarify.

If you have a sample file where you reproduce this issue, I'd be interested in taking a look.

Hmm, not sure. The file is huge because it has a LOT of data, and a lot of that data has customer info in it. I can make a copy and see what happens if I try deleting some of the tables...

That is what I meant. It works for me, at least in some cases. Sorry to hear it didn't help.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.