Skip to main content
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Advocate I
Advocate I

Add button disabled in App Source

After updating to the April 2022 version of PBD, I'm unable to add more visuals.

When accessing the AppSource and selecting the visual I'd like to add, the Add button appears disabled. At one point there was a tooltip indicating it was trying to log me in.

I tried signing out and signing back in. I also tried uninstalling and reinstalling Power Bi without success.

Is there something I am missing? I




Advocate I
Advocate I

I'm not sure how this was solved, but after a few seconds, the Add button gets enabled.



View solution in original post

Advocate I
Advocate I

I'm not sure how this was solved, but after a few seconds, the Add button gets enabled.



Same here, feels like a universal blip 😄. Good to see it back in action.

I've got the same issues here too since my last update. It's actually tiring when one can't add a visual directly from the app

Frequent Visitor

I've noticed this recently too. I was wondering if Microsoft had implemented an admin center setting that restricts the appsource, but it wouldn't make sense, as you could previously get visuals from the appsource without Power BI Desktop being signed in. That tool tip to say you're being signed in on the add button is something I saw too. Which makes me think that you need to be signed in to check to see if you are allowed to get visuals from the appsource based on your org settings. Not ideal...

Not applicable

Same issue here, can login manually and download from the webpage and import the downloaded file but thats really inconvenient.

Yes. That's the workaround on the meantime.

Frequent Visitor

Same issue as many other.

It seems to work for me in the Browser so to get around it temporarily while making a report in the desktop app I published it, opened it in the browser, started editing, added my desired visual, downloaded, then opened again in Desktop with the visual now added.

Regular Visitor

I am also facing same issue.  Any solution ?

Regular Visitor

I'm having the same problem. my version is Power Bi Desktop(يناير2022) RS


Regular Visitor

Same issue here. Looks to be disabled on all the visuals. 

Regular Visitor

Same issue here 😐

Regular Visitor

Same issue here....

Frequent Visitor

Same issue here.  The add button in the AppSource is disabled for everything.

Same for me but only in my ordinary Power BI desktop.

If I try the same in a Microsoft MOC Lab, it works fine... weird

Frequent Visitor

I'm having the same problem. Was working fine yesterday.

Reporting same issue.

Advocate II
Advocate II

I am having the exact same issue, the report I am using already has three custom visuals, and is more than a year old. 

Helpful resources

Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors