Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Regular Visitor

Regarding ML for forecast using ARIMA model

Hello everyone,

I'm using a code written in Jupyter Notebook for forecasting demand and on the Jupyter Notebook it's working just fine, When I tried to streamline the process by using this code in synapse notebook inside the Fabric environment, I end up with the following error



3.10.10 Fitting the model... com.fasterxml.jackson.databind.exc.MismatchedInputException: No content to map due to end-of-input at [Source: (String)""; line: 1, column: 0]



I tried some solutions for my assuption which are>

1-After some research, I understand that the Fabric Notebook is running with Pyspark engine which is an architecture for disruption for Big Data. Which is not good for using regular Python packages such as statsmodels that I'm using for my model. To solve this I changed the setting of the workspace to use only 1 cluster which theoretically should behave like regular Python Environment


2- I thought that the environment is missing some dependencies, so I added all the needed dependencies for statsmodels in the workplace but also it didn't work.

I would be thankful if anyone can help with this. 

Frequent Visitor

I found that using the parameter disp=False worked for me.


Frequent Visitor

Did you find a solution to that issue?

Community Support
Community Support

Hi @Greemreb Thanks for posting your question in Microsoft Fabric Community

Can you please share some screenshots of the error and the exact steps you have followed 




Hi, I have encountered a similar issue.  The code works fine in Juptyer Notebooks but not when in Fabric environment.  Mine looks like this:


Any help would be much appreciated as struggling to find any answers


I saw the answer in another page. Run this on a cell


import com.fasterxml.jackson.core.JsonParser.Feature;
import com.fasterxml.jackson.databind.ObjectMapper;

StatusResponses loginValidator = null;

ObjectMapper objectMapper = new ObjectMapper();
objectMapper.configure(Feature.AUTO_CLOSE_SOURCE, true);

try {
    String res = result.getResponseAsString();//{"status":"true","msg":"success"}
    loginValidator = objectMapper.readValue(res, StatusResponses.class);//replaced result.getResponseAsString() with res
} catch (Exception e) {

the autor doesn't know how it worked, but it worked.


It worked for me. I had the same problem

Thanks for the advice!  I'm getting this error message when running that, did you come across anything similar?



Helpful resources

Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Expanding the Synapse Forums

New forum boards available in Synapse

Ask questions in Data Engineering, Data Science, Data Warehouse and General Discussion.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.


Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

Top Kudoed Authors