Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate I
Advocate I

Cannot list Files or Tables in a Lakehouse

Hi All, 


I have activated Fabric on my tenant and I am the Power BI admin of the tenant, I have also activated Fabric trial, but whenever I create a workspace in a Trial capacity and try to create a Lakehouse I get these errors shown in the images below:




I have opened a support ticket to MS, but has anyone faced with a simillar issue or knows what I need to to to fix this?


The SQL Endpoint is working fine in the meantime I can connect to it. 


Thanks in advance, please let me know if you need additional info.


Kind regards,



I check my all setting from admin and logout from fabric. Restarted Machine and install onelake

View solution in original post

Community Support
Community Support

Can you re-login and see if the error still exists, I think some issue related to access as Endpoint is created.

The files are accessible using notebook. I created three directories using python and are listed using python




Good to know, so the issue is only with Lakehouse

@GeethaT-MSFT , @wahmed20 I think I made progress with this issue, and I think the issue is with my machine not beeing in the same domain as the Fabric account (working as a contractor for a company).
@wahmed20 Have you tried instaling the OneLake File Explorer, I think this caused the issue on my side. Yesterday I spinned up Win 10 Virtual Machine in the subscription of the customer I am working for and from that VM I do not see the issue:



So now the question is is there a way to work on the OneLake and the Lakehouse from a machine that is not in the same domain as the MS Fabric account?



@flowerkowski  Good to know that your issue is not resolved and Thanks for sharing the information here with the community 

Thank you, but one lakes crashes after entering login information

Same for me, but I am logged in on my laptop with anoter email/domain and I try to log in to OneLake with a different one, maybe this is the issue.

I am logged in with company laptop and entering company credentials into onelake it does not listed in FileExplorer

It is now working, the successful installation of OneLake make it to work.

How did you manage to reinstall it after the login crashes? Thanks a lot. 

I check my all setting from admin and logout from fabric. Restarted Machine and install onelake

Thanks a lot, this solved my issue also, accepting it as a solution, have a nice day @wahmed20 

Refreshing the folder gives 



No still there is problem.
Even Creating the subfolder give error



Community Support
Community Support

Can you please share the steps you have followed?


First I click the Lakehouse


and I name it lakehouse_test, then following screen appear


As you can see red sign before the Folders, there are not loading. On clicking them, I get 


Only the SQL endpoint is loading. 
Additionally uploading file does not work as well

Resolver I
Resolver I

I had the same issue,my table and files folder are also not loading

Community Support
Community Support

No, I don't see this error, So you just created a Lakehouse in fabric and you see this error?



Is it due to trial version or not having mircrosoft BI Pro

Yes, additionaly I tried to install the OneLake desktop client and it is not working, the errors in the diagnostic log files are something like this:

status: Forbidden [403]. GET


ERROR|Initialization of core failed: Microsoft.OneLake.FileExplorer.Common.Exceptions.LakeStorageErrorException: OneLake is not supported for the current tenant f91cd4eb-xxxxxx-xxxxxxx-xxxxx-xxxx. (Forbidden)

I have Fabric enabled at that same tenant:




Helpful resources


Fabric Monthly Update - June 2024

Check out the June 2024 Fabric update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.