Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
eml
Regular Visitor

Schedules refresh on local datasources

I am publishing a report to the service which uses local datasources (an on-premise mysql and some files) and I want to schedule refresh using a personal gateway. The files are located on the same machine that hosts the mysql db.

 

The files are created as a local connection, assigned a gateway cluster, and can connect over the personal gateway just fine.

The mysql connection however is created on the service as a cloud connection, and throws authentification errors when trying to connect.

 

eml_0-1718374123739.png

 

 

If I try to create a new on-premise data connection, the service won´t allow me to pick or input anything for Gateway cluster name.

eml_1-1718352545256.png

The local gateway seems to be fine, the logs from testing report only successful connection.
Uploading a report with just the connection to the on-premise mysql results in powerbi telling me that I don´t need a Gateway, since all my sources are cloud-based (which they are not - but is consistent in powerbi creating my data source as cloud-based, I guess). 

 

and the obligatory final clause - this used to work until a week ago or so, and nothing I could think of has changed on our side of things.

 

Any ideas on how to fix this?

1 ACCEPTED SOLUTION

Yeah - I found the documentation not the clearest, but once I'd set up the enterprise gateway (wherever you have the personal gateway set up), I then went into Power BI service 'manage gateways and connections' within the gear icon.

 

Then, like your second image (new connection with gateway cluster), there is a MySQL option under connection type which appears once you've picked a gateway- enter your credentials in there and check it works.

 

Then, within each reports settings, in the gateway section, you need to map each connection from the dataset to the relevant connection you've set up in service (in the top section - gateway, not the bottom cloud one).

 

Sorry if this makes zero sense!

View solution in original post

6 REPLIES 6
eml
Regular Visitor

thanks for your reply!
i tried all the possible permutations of privacy levels - to no avail.

MainlineData
Helper I
Helper I

I'm finding a similar issue - try as I might - I cannot get a local file / folder to work through enterprise gateway (but used to be fine with personal gateway).

 

Frustratingly, you will need to set up MySQL through an enterprise gateway now for it to schedule as it will try be a cloud source now through a personal gateway, I had the same issue and kept getting told to move to enterprise from personal (but no one would acknowledge whether the behaviour was expected or an error).

 

But, now all MySQL connections go through the enterprise gateway, I can't get my local files to work.

HI @MainlineData ,

thanks for your reply. The odd thing is that the local files work fine. It´s just the Mysql which gets "defaulted" to cloud.

But now that you have the enterprise gateway, can you connect through it to your local Mysql source?

Yeah - I found the documentation not the clearest, but once I'd set up the enterprise gateway (wherever you have the personal gateway set up), I then went into Power BI service 'manage gateways and connections' within the gear icon.

 

Then, like your second image (new connection with gateway cluster), there is a MySQL option under connection type which appears once you've picked a gateway- enter your credentials in there and check it works.

 

Then, within each reports settings, in the gateway section, you need to map each connection from the dataset to the relevant connection you've set up in service (in the top section - gateway, not the bottom cloud one).

 

Sorry if this makes zero sense!

that worked 🙂 thanks!

 

little caveat: when you create the data connection to map to the company gateway, the name of the connection needs to match exactly the name of existing, missing data source. This way it seems to work for both local files and the local database.

SaiTejaTalasila
Solution Sage
Solution Sage

Hi @eml ,

 

Try changing the privacy level on the connection you are using it may fix the issue.

Thanks,

Sai Teja 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.