Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
maracles
Resolver II
Resolver II

Refresh Now and Scheduled Refresh Not Working

We have been using Power BI for several months now and have used Scheduled Refresh with very few issues. However the last week we have been experience increasing issues, and then today we cannot update at all.

The first issue we've been experiencing is as follows:

  • PowerBI would not refresh in the morning. Out last refresh at 11pm would work, but then nothing would refresh the following day unless we manually went in and click 'Refresh Now'. One we had done this the rest of the days scheduled refreshes worked as expected.

 

The second issue that we're are having as of today is as follows:

  • 'Refresh Now' no longer runs. When I click it a notification appears for half a second saying that a refresh is happening and disappears, however the refresh does not complete. Usually there would be a loading indicator next to the dataset name - this is also not here.
 

Can anyone help troubleshoot these? Right now the only way of updating the data is me refreshing the POwer BI Desktop file and publishing. I do not want to be doing this manually 8x every day!

We only connect to one data source and that is our MySQL database, under credentials everything looks fine.

Thansks.

 

1 ACCEPTED SOLUTION
v-sihou-msft
Employee
Employee

@maracles

 

In this secnario, I suggest you check the logs first.

You can see On-premises data gateway service logs under: 

C:\Users\PBIEgwService\AppData\Local\Microsoft\on-premises data gateway\Gateway*.log

And On-premises data gateway service event logs  under Application and Services Logs.

 

Then please restart enterprise gateway service via command:

net stop PBIEgwService

net start PBIEgwService

 

If the issue still persists, I suggest you uninstall Enterprise gateway and install latest version On-premises data gateway. For more details, please see: Troubleshooting the On-Premises Data Gateway

 

Regards,

 

View solution in original post

22 REPLIES 22
Frostbyte
Regular Visitor

It is August, 2017, and this problem is still present.  Are the Power BI developers even concerned that their software contains so many bugs such as this?

lili3103
New Member

Hello everyone, when i click on refresh now PowerBI.com  it says that that a refresh is happening, but then nothing would refresh and no failure notification appears 

pjn
Frequent Visitor

I've just noticed that our dashboard has stopped refreshing since 16th January. All CSV files are stored in OneDrive for Business and accessed using Csv.Document(Web.Contents()). This has been working perfectly since end of last November and nobody has republished or changed settings since then.

 

Checking credentials showed that approx half of our oAuth2 data sources had 'lost' the credentials. Fixed these and tried again but refresh is still failing with the message "An unknown error has occurred. Please try again. If the issue continues, please contact support".

 

The company I'm doing this small dashboard for is rapidly losing faith in this solution. The project was almost scrapped back in November when there was an ongoing issue saving credentials (reported by a number of people in the community) that took a few weeks to be fully resolved. I'll be getting called back in tomorrow at my own expense to explain to them why I can't fix it, and will yet again have to defend Power BI as a suitable system for their usage.

 

EDIT: A few hours later and things seem to be working again now. Hopefully tomorrow's scheduled refresh will work as expected to save me a trip to this client's office.

 

 

 

Jasper
Advocate I
Advocate I

Same problem here..
"Refresh Now" shows a loading indicator for 5 seconds and then it marks the on demand refresh as done or

it keeps showing the loading indicator and nothing happens..

 

Check/ vote also: http://community.powerbi.com/t5/Issues/idb-p/Issues

alexdrenea
Regular Visitor

Our Azure Enterprise connection refresh is been failing for about 2 days now. Reports that credentials are bad, but I've regenerated all keys and everything should be in order.

mysterbiggs
Advocate I
Advocate I

Also having the same issue in West-US. All of our dashboards are scheduled across several enterprise gateways and suddenly today, they just stopped refreshing. Not failing, but not running at all. 

uk_tj
Advocate IV
Advocate IV

Starting to get failure notifications. Thats progress I guess...  Smiley LOL

uk_tj
Advocate IV
Advocate IV

Same issue here. Currently only way to refresh a report is to re-publish it...

 

Edit: Not receiving any failure notification either

we need to make sure Microsoft is working on this. they refer to this community for any errors but does anyone know the nick of any of the microsoft representatives on the bord so we can tag them?

Maybe MiguelMartinez ??

We've had this issue too for approx 27hrs.

It is affecting direct connections as well as things through the gateway.  We've reinstalled the gateway, checked the gateway logs etc.

I'm logging it with Microsoft support now....

 Message about NorthEurope has appeared on the website within the last hour or so:

 

Customers in North Europe may see intermittent problems refreshing their datasets or credentials.Power BI team is actively investigating the issue. Next update 01/17/2017 08:00 PST.

blueant
Frequent Visitor

it seems well 12 houers ago , but it happend again now

Also intermittent for me...

All my reports did a refresh yesterday around 23:30

Today some reports are running to their schedule other not.

I'm getting no failure notifications at this time.

Randomly getting logged out of the desktop app which requires a reboot to rectify.

Only way I can currently refresh a report with certainty is to re-publish it

kcantor
Community Champion
Community Champion

I currently have an open ticket on this. Here is the latest from the team.

Hi Kristi,

 

I hope you are doing well. Thank you very much for your time and patience in this matter.

 

I have reviewed the Activity ID you provided during our troubleshooting today and I engaged the product Group to get their insights and assistance to resolve this issue. It seems that it is an issue that the Product Group is actively working to fix.

 

I will keep investigating the issue further with the Product Group meanwhile I will keep you updated.

 

Thank you very much again for your time and patience.

 

I hope you have a wonderful day!

 

Best regards,





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




kcantor
Community Champion
Community Champion

Spoke with tech again today. One fix has already been pushed out. It did not help me but maybe helped with some of your issues.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




Started working for me today. Awesome.
v-sihou-msft
Employee
Employee

@maracles

 

In this secnario, I suggest you check the logs first.

You can see On-premises data gateway service logs under: 

C:\Users\PBIEgwService\AppData\Local\Microsoft\on-premises data gateway\Gateway*.log

And On-premises data gateway service event logs  under Application and Services Logs.

 

Then please restart enterprise gateway service via command:

net stop PBIEgwService

net start PBIEgwService

 

If the issue still persists, I suggest you uninstall Enterprise gateway and install latest version On-premises data gateway. For more details, please see: Troubleshooting the On-Premises Data Gateway

 

Regards,

 

@v-sihou-msft

 

We have an enterprise gateway installed and the schedule refresh was happening successfully.

However we are experiencing the above issue right now 

with these concerns 

1.log is empty(for the current day, last logged previous day when refresh happened)

2.Services were restarted

3.Latest Enterprise gateway installed.

 

Still issue persists...

 

Any help would be greatly appreciated

 

Thanks,

Vignesh

 

 

Have the exact same Scenario. Have 15 datasets and none have refreshed since 15hrs ago.

The "next scheduled refresh" is 5 hours ago and that usually changes for later (like if microsofts clock is off)

Everything refreshed through on premises before but installed a gateway just to try but to no change.

One of the datasets is googe analytics and on that set it sais the credentials anr wrong but they´re not.

Feels like the problem is on Microsofts end..

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors