Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Danniel
Advocate I
Advocate I

Problem with scheduled refresh error Expression.Error: The field 'SPRequestGuid' of the record wasn'

Hello all, I had a Power BI report with a refresh error that had been working propertly for the last few months, today I had an error that starts with: 

 

Expression.Error: The field 'SPRequestGuid' of the record wasn't found.

 

Apparently targeting some table that comes from sharepoint. The think is that the report works perfectly on power bi desktop and doesn't give me an error never. 

1 ACCEPTED SOLUTION
Zalina
Advocate I
Advocate I

So now Microsoft is closing my ticket with these clorure notes, not sure what that means I should do in the meantime:

This is to inform you that, this is a Known issue from the Product, which was recently acknowledged. Please be assured that our product team is continuously working on the ongoing issue.
Apologies for the inconvenience caused on behalf of Microsoft.
 If you need any further assistance on this case then please feel free to reach out to us, If there are no queries other than this, may I know can we close the service request.
 


View solution in original post

38 REPLIES 38
SaiTejaTalasila
Solution Sage
Solution Sage

Hi,

Please open 'Transform Data' and check the applied steps for that SharePoint table one by one, from the source to the end steps. This will show the error. Also, turn on column quality and check the errors %  for every column.

This was a known issue acknowledged by Microsoft and had nothing to do with data quality.
The issue has since been resolved.

Zalina
Advocate I
Advocate I

The issue has been fixed. And the scheduled refresh is working again 🎉

oyasin
Frequent Visitor

Issue should be fixed now.

DDDDD
Frequent Visitor

Same here, failed a few days ago coincidentally around the time we had some microsoft updates or patches so probably introduced some error.

I've not changed anything on SharePoint or the report which was working fine.

I'll try the suggestion of changing to imp.1 but @Microsfoft!! please fix this asap... and don't add bugs in your updates 😉

Zalina
Advocate I
Advocate I

So now Microsoft is closing my ticket with these clorure notes, not sure what that means I should do in the meantime:

This is to inform you that, this is a Known issue from the Product, which was recently acknowledged. Please be assured that our product team is continuously working on the ongoing issue.
Apologies for the inconvenience caused on behalf of Microsoft.
 If you need any further assistance on this case then please feel free to reach out to us, If there are no queries other than this, may I know can we close the service request.
 


Predrag_GG
Frequent Visitor

As someone mentioned, automatics refresh working when you turn on the gateway to the sharepoint location

Zalina
Advocate I
Advocate I

New update on my Microsoft ticket:
"Thanks for your confirmation. This is to inform you that we are working and investigating the issue with our higher ups, and we will get back to you as soon as possible."

oyasin
Frequent Visitor

it do work if you assign an on prem GW then refresh will work.

issue seems to be with SPO side.

doesn't look like a feasible solution:

Zalina_0-1714467292578.png

 

oyasin
Frequent Visitor

you need to have a GW installed then you can use it here.

xdaskalopoulou
Regular Visitor

Daniel , is it fixed on your end ? 

not yet
FarhanZ
New Member

I had the same problem since Friday. The only workaround I can think off is to download the pbix file, refresh it on PowerBI Desktop and republish it to workspace. 

Created a ticket as well, just haven't receive any update from them. 

Oh that will work ? Remove from workspace and then publish it again ? My issue is the auto refresh , the Pbix is refreshing on desktop the auto refresh is showing the SPRequestGuid

I did what was described above but didn't manage to get autorefresh working... 

Predrag_GG
Frequent Visitor

Same issue here,...

BDobbins
Frequent Visitor

Been having the same issue off and on for the past couple weeks.

roregan
Regular Visitor

Same here. I've had mixed success with deleting the query from the service, clearing permissions, and republishing--not a 100% reliable fix, though. 😕

BenderBendingRo
New Member

I have the same error. I could connect with Implementation mode 1.0 but and add new tables to my dataflow. But those which I connected with Implementation mode 2.0 in the past have all failed to refresh and load.  :')

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.