Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Tradeexcel
New Member

Power BI Premium Activation

I have purchased a Power BI Premium License but my workspace  settings is showing Pro and Premium button is disabled. Can someone please help to activate the premium license. Thanks

1 ACCEPTED SOLUTION
v-heq-msft
Community Support
Community Support

Hi @Tradeexcel ,
Based on your description, first, make sure you have the permissions you need to view and modify the advanced settings. If you are not a capacity administrator, or if you do not have permissions assigned, the advanced settings may not be visible or editable. Second, make sure that you have either a Power BI Pro or Premium Per User (PPU) license assigned to the user account, as one of these licenses is required to create content and assign the workspace to the advanced capacity.
You can refer to these documents for more information
How content is organized in workspaces - Power BI | Microsoft Learn
Types of licenses for Power BI business users - Power BI | Microsoft Learn
Manage your Fabric capacity - Microsoft Fabric | Microsoft Learn
Solved: changing workspace to premium capacity - Microsoft Fabric Community

Best regards,
Albert He

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

View solution in original post

6 REPLIES 6
v-heq-msft
Community Support
Community Support

Hi @Tradeexcel ,
Based on your description, first, make sure you have the permissions you need to view and modify the advanced settings. If you are not a capacity administrator, or if you do not have permissions assigned, the advanced settings may not be visible or editable. Second, make sure that you have either a Power BI Pro or Premium Per User (PPU) license assigned to the user account, as one of these licenses is required to create content and assign the workspace to the advanced capacity.
You can refer to these documents for more information
How content is organized in workspaces - Power BI | Microsoft Learn
Types of licenses for Power BI business users - Power BI | Microsoft Learn
Manage your Fabric capacity - Microsoft Fabric | Microsoft Learn
Solved: changing workspace to premium capacity - Microsoft Fabric Community

Best regards,
Albert He

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Thank You 

Tutu_in_YYC
Resident Rockstar
Resident Rockstar

Did you purchase Premium Per User (PPU) or Premium Capacity?

As you have seen, it will be an option on your workspace settings. PPU will appear automatically if you have it, and all the users in the workspace must have it in order to turn it on on an existing workspace.

For Premium Capacity, you need to be an admin of the capacity, that when the option will not be greyed-out.

Thank You

SaiTejaTalasila
Solution Sage
Solution Sage

Hi @Tradeexcel ,

 

You can try to create a deployment pipeline and check ,if it works that means you have a PPU license otherwise it's not activated.These is how I will check for my users.

 

Thanks,

Sai Teja 

 

Spoiler
I solved this by creating a new work space - Thank You 

Helpful resources

Announcements
PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.