Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Frequent Visitor

Pipeline Deployment - Parameter Rules not Visible

The Parameter Rules I set are not visible, but they are being applied.  

I developed a proof of concept and the parameter rules seem to have glitches. I set up a rule in Test but when I go to check it, it states I have no rules. I set up a rule in PRD, when I check it, its the rule I created for Test. When I deploy through the stages, the rules I actually configured do get applied, regardless of what they say at each stage.
Am I making a mistake, is this known or just unique to me? 
Additional context, I am using parameter rules to alter the datasources through environments. I cannot use the data source rules because Databricks is not a supported source.
Community Support
Community Support

Hi @tctrout2 ,

There are some possible solutions or workarounds that you can try:

Make sure that you have enabled the Field parameters feature in the Preview features settings.
Check if the parameter rules are valid and consistent across the stages. Sometimes, Power BI may show an Invalid rule error when changing data sources or parameters.
Refresh the report or dataset after applying the parameter rules. Some users have found that the parameter rules are not visible until they refresh the report or dataset.
Re-create the parameter rules or delete and re-add the parameters. This may help to resolve any glitches or inconsistencies in the parameter rules.

Let report readers use field parameters to change visuals (preview) - Power BI | Microsoft Learn

Solved: Deployment pipelines Parameters Invalid Rule - Microsoft Fabric Community

Add or modify available values for a Power BI paginated report parameter - Power BI | Microsoft Lear...


How to Get Your Question Answered Quickly 


If it does not help, please provide more details.


Best Regards
Community Support Team _ Rongtie

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.


I tried all the proposals and it still did not fix the issue.  I am using GCC instances of Power BI, is this a bug?

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors