Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Regular Visitor

No data when model is online



I've made a model with many tables and reports and everything connected and when i upload the model online some of the tables contain no data. I've tried and deleted paraametars and entered them again still the same. When i refresh in desktop everything is working fine, the data is flowing and tables are refreshed, the problem arrises when the model is online. Refresh gets done, report is that refresh is successful, but some tables are empty. I have sources from Azyre, Onedrive for excels, Odata and SQL. All are ok, except for Azyre, where from 6 tables only one is having data. Lastly i have made several versions of the file, each with different relationships deleted to one of the tables that doesn't get data, to try and isolate the problem. Anyone having some idea what might cause this or having encountered similar issue and solved it? Thanks


Hi @Dimitar_Gorgev ,

All in premises data source are needing a gateway to push the data to the web. If you use on premises data source as direct query the data couldn't appear without gateway which pushes the data into your report :).








If this post has helped you, please give it a thumbs up!
Did I answer your question? Mark my post as a solution!




just to keep you updated:

-Yes, one drive is web address, but as i said, the trouble is with the sql sources

-Yes, there is a gateway connected with the sources to fetch data


from 7 tables sql data coming from salesforce, only one was getting updated with data from other countries although filters are set and i should only view my country. my user also contains restriction to view data from my country.


I escalated the issue with IS in the company and we are testing with:


-New user

-New pbix without relationships or calculations, just plain raw data, just the sql and odata sources, i get a timeout error after 10-15min although timeout is set to 60min

-Personal gateway instead of onpremises and still the same timeout error

-Querries are rewritten and optimized for fast loading, our central IS is gets them in 3min and locally i need 4hours to fetch one table

-Dataflows for each source to easy up the fetching, 3 tables (most data demanding) again with timeout error and cannot be set. for tables from dataflows, refresh is 5-10 times quicker


my biggest table is with 7m rows, so not something too big

Still no solution in sight, hopefully i will be able to share the solution for everybody's knowledge. again as a reminder, the local workstation with dual xeon and 32gb of ram refreshes everything in two steps ~two days of work. 



Super User
Super User

Are you sure that the Onedrive connection is pointing to the web location and not your local sync copy on your PC?

Helpful resources


Fabric certifications survey

Certification feedback opportunity for the community.


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors