Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Filled map - one georgraphical area not displaying

Hello,

 

I am having a problem with a filled map visualisation. I am displaying data by Local Authority Council areas in Devon, United Kingdom - all the local authority areas display fine with the exception of one, and I wonder if anyone knows why - the problem area is "E07000043. NORTH DEVON"

 

Note the above code & name format is the only way I can get the area data to display - nothing loads if I just use the GSS codes on their own eg E07000043, or the local authority names on their own eg NORTH DEVON.

 

Also the filled map only seems to work when the Data Cateory is set to 'City'.

 

Any advice would be appreciated!

Thanks

 

A sample of the data I am using:

 

UniqueRefLA Code + Name
14KE2A001E07000040. EAST DEVON
14CB2W001E07000043. NORTH DEVON
14JS3N001E07000044. SOUTH HAMS
14KT3E001E07000042. MID-DEVON
14JC2B001E07000045. TEIGNBRIDGE
14JC3H001E07000045. TEIGNBRIDGE
14JC3H002E07000045. TEIGNBRIDGE
14JS2K001E07000044. SOUTH HAMS
14DE2I001E07000041. EXETER
14JI4M001E07000044. SOUTH HAMS
14DE2M001E07000041. EXETER
14KA2J001E07000040. EAST DEVON
14KH2H002E07000040. EAST DEVON
14CI2D001E07000043. NORTH DEVON
14CL2C001E07000043. NORTH DEVON
14JH2H001E07000044. SOUTH HAMS
9 REPLIES 9
Greg_Deckler
Super User
Super User

Oddly enough, the only one that I could seem to get to work was NORTH DEVON. I entered your sample data and here is what I got.

british.png

 


Follow on LinkedIn
@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...
Anonymous
Not applicable

Hi, thanks for your replies, I will post in the other forum you kindly suggested.

How strange that you get the opposite output to me! I can see one difference though - your Values field is blank, I placed the unique ref field in there. Perhaps that made a difference somehow?

Anonymous
Not applicable

Capture - Missing North Devon.JPG

The 'Values' field well determines shading. It's hard to tell from your screenshot. Do you have very few entries for that particular area? It may be that it's being shaded but so lightly that it seems invisible.

 

You can change the data colors in the visual 'Format' menu (the paintbrush under the visuals pane). Try changing the min value to something that's not white and see if it shows up.

Anonymous
Not applicable

Hello, thanks for your reply. North Devon has a healthy amount of records (47 out of approx 300 records). Also I noticed when I hover over the other areas on the map an area label appears, but hover over the North Devon area and nothing happens. 

As you will see below, North Devon shows up in a different chart type but as soon as it switches to a map type output then it mysteriously vanishes from the results!

 

Capture - North Devon within treemap.JPG

 

Okay, cool. I just wanted to rule out that as a possibility. When you search in Bing maps, is that area located appropriately?

 

I'd submit a bug if I were you. You can do so in PBI Desktop by using the 'Send a frown' option in the File menu, or by opening a ticket here for bugs in the PBI Service.

The forums are a great avenue for discussing issues, sharing thoughts / ideas, and troubleshooting, but they are not the official medium to submit bug reports.

Proper bug reports will receive more attention from the devs than forum posts.

Anonymous
Not applicable

Sure.. Also judging by a reply I got in the Bing maps forum, this is sounding more and more like a bug rather than user error!

Will do, thanks for your advice 🙂

I too am getting the issue with whole post code areas being missing.

 

I have alist of UK postcode sectors (AB, AL, B etc.)  and I have been using Power maps in Excel with the same date to colour code a national map based on frequencies, rates and other values.

 

When I use the same data in POwer BI, a handful of postcode sectrs are not filled in at all.  when clicking on the area, no pop up o ccures - telling me it has not drawn the area at all.

 

Specifically, B, SA, and SE are showing as holes in an otherwise perfectly drawn UK map.

 

Does anyone have any pointers as to why this might be going wrong?

Greg_Deckler
Super User
Super User

Power BI uses Bing to geocode the data, so you might be better off asking this question in their Developer Forum, etc. https://www.microsoft.com/maps/developer-resources.aspx

Follow on LinkedIn
@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors