Forum Discussion

Anonymous's avatar
Anonymous
Not applicable
4 years ago
Solved

Deployment Pipeline - Problem with the gateways in the prodution workspace

Hello everyone,  I currently have a parameter rule on my dataflow when I deploy it in production.  However, when I deploy and go back into my workspace and into my Dataflow settings, I cannot apply...
  • v-kkf-msft's avatar
    4 years ago

    Hi Anonymous ,

     

    It has to do with the limitations of the dataflow.

     

    Dataflows considerations and limitations :

    • Deleted datasources are not removed from the dataflow datasource page.
    • Deleted datasources will still appear in the Setting page in the gateway drop-down.

     

    Here are the steps of my test.

     

    1. Create the following rule in the Test workspace and change the parameter to "Project B". At this point the data source is updated to an excel file named Project B.

     

     

    2. Create the rule in the Production workspace and change the parameter back to its original value (i.e. the same value as in the Development workspace).

     

     

    3. Then compare the gateway for this dataflow in the Development/Test/Production workspace. It can be noticed that even though the parameter value in the Production workspace is the same as in the Development workspace, it still retains the deleted data source (project b), so the gateway indicates a configuration error. It is worth noting that this does not affect the refreshing of the dataflow in Production workspace.

     

     

    If the problem is still not resolved, please provide detailed error information or the expected result you expect. Let me know immediately, looking forward to your reply.
    Best Regards,
    Winniz
    If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.