Forum Discussion
Deployment Pipeline - Problem with the gateways in the prodution workspace
- 4 years ago
Hi Anonymous ,
It has to do with the limitations of the dataflow.
Dataflows considerations and limitations :
- Deleted datasources are not removed from the dataflow datasource page.
- Deleted datasources will still appear in the Setting page in the gateway drop-down.
Here are the steps of my test.
1. Create the following rule in the Test workspace and change the parameter to "Project B". At this point the data source is updated to an excel file named Project B.
2. Create the rule in the Production workspace and change the parameter back to its original value (i.e. the same value as in the Development workspace).
3. Then compare the gateway for this dataflow in the Development/Test/Production workspace. It can be noticed that even though the parameter value in the Production workspace is the same as in the Development workspace, it still retains the deleted data source (project b), so the gateway indicates a configuration error. It is worth noting that this does not affect the refreshing of the dataflow in Production workspace.
If the problem is still not resolved, please provide detailed error information or the expected result you expect. Let me know immediately, looking forward to your reply.
Best Regards,
Winniz
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Hi Anonymous ,
It has to do with the limitations of the dataflow.
Dataflows considerations and limitations :
- Deleted datasources are not removed from the dataflow datasource page.
- Deleted datasources will still appear in the Setting page in the gateway drop-down.
Here are the steps of my test.
1. Create the following rule in the Test workspace and change the parameter to "Project B". At this point the data source is updated to an excel file named Project B.
2. Create the rule in the Production workspace and change the parameter back to its original value (i.e. the same value as in the Development workspace).
3. Then compare the gateway for this dataflow in the Development/Test/Production workspace. It can be noticed that even though the parameter value in the Production workspace is the same as in the Development workspace, it still retains the deleted data source (project b), so the gateway indicates a configuration error. It is worth noting that this does not affect the refreshing of the dataflow in Production workspace.
If the problem is still not resolved, please provide detailed error information or the expected result you expect. Let me know immediately, looking forward to your reply.
Best Regards,
Winniz
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
- Anonymous4 years agoNot applicable
Thank you for your answer however, I can't apply my gateway so I can't refresh my dataflow, because I have non-prod data sources for the DEV and TEST environment and a prod data source for the PROD environment.
- v-kkf-msft4 years ago
Community Support
Hi Anonymous ,
As my previous screenshot shows, my Production workspace gateway is also showing a configuration error message, but without having to deal with it, and refresh the dataflow directly will still succeed. This is because the dataflow in Production workspace actually contains only the "project a" data source.
If you are still unable to refresh, then please try clicking on the "Add to gateway" link to add all the data sources shown in this drop-down list to the gateway.
If the problem is still not resolved, please provide detailed error information or the expected result you expect. Let me know immediately, looking forward to your reply.
Best Regards,
Winniz
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.