Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Shamasunder
New Member

Datasource rules in deployment pipelines are not working as expected

I am trying to change the datasource for my dataflow in deployment pipelines but its not changing. When I replace the datasource with the new link in datasource rules its changing as expected. But when i go and check in the dataflow or report it shows the old datasource. 

How can i replace the dataflow datasorce in deployment pipelines???

Thanks in advance.

3 REPLIES 3
v-yueyunzh-msft
Community Support
Community Support

Hi , @Shamasunder 

Based on your issue description and feature mentioned, I think you have successfully depoyed the pipeline rule to change the datasource definiton for the dataset when processing the deployment pipeline to change your dataset configuration from old one to the new one, but the data still showing the old one?


If correct, would you like to kindly go to the dataset setting of this dataset to check the datasource defined for this dataset currently and make sure it's the latest?

vyueyunzhmsft_0-1685505236506.png

If no, you may need to check your pipelie rule again to make sure the rule is correctly configured. If yes, you can simply click on the "refersh history" to make sure if there's any succeeded data refersh after the data source definition changed?

vyueyunzhmsft_1-1685505252304.png

If no, this means the data from the new datasource hasn't been loaded in after the datasource definition changed, you need to refresh once to load the data in. If yes, you can simply go to the report again to click on the visual refresh again to make sure all the visuals now can display the data from the new data source came in:

vyueyunzhmsft_2-1685505269745.png

And then the issue should disappear. Thanks!

 

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Hi Aniya, Thanks for the reply. I am trynig to set the datasource rules for dataflow and not dataset. My dataset data is coming from the dataflow. 

ShamaSunder_r_0-1685508994864.png


I am trying to replace the below sharepoint datasource in dataflow.

ShamaSunder_r_1-1685509173691.png

 

in below image it shows the datasource is successfully replaced.

 

ShamaSunder_r_2-1685509354683.png

 

But when i check in dataflow entity source it still connected to the old datasource. 

ShamaSunder_r_3-1685509643062.png

I tried refreshing the dataflow and dataset multiple times. but still datasource is not replaced.

Thanks,
Sunder.

Hi , @ShamaSunder_r 

Thanks for your reply~

I test in my side , the pipeline rules works good .

For this , you need to check if you have deployed it to the target worksapace.

vyueyunzhmsft_0-1685515225284.png

If you do not do this deployment action, the rules will not work.

And when i deployed to another worksapce successfully , the data souce has been replaced:

vyueyunzhmsft_1-1685515290427.png

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.