cancel
Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Reply
G_CR_23
Frequent Visitor

Connection Error: Your file was published but disconnected

Hi all,
i'm facing some issues with a composite model (1 pbi dataset, 1 googlesheet and 1 table from a sql server).

When i publish there is an error message "Your file was published but disconnected".

In the dataset settings there is also a message " One or more cloud data sources for this dataset have been deleted", but it is a new report...

I can't select the gateway because it says gateway is not reacheable, but this is not true, because al the other report is updating.

Also, the pbi dataset come from the same sql server of the table, so i already have a gateway installed and with all the credentials, in fact all the data are updating.


 

I can't understand if this is an error just for this specific work area or for this report.

Can someone please help me?

TY so much,

Gianluca

9 REPLIES 9
PunchBird
Helper V
Helper V

Hi all, I got this message as well, but for a Dataflow which shouldn't need a gateway. So first check if any of the data sources you are connected to needs a gateway. If not, then go to 'Manage connections and gateways', under the tab Connections. In my case there were  2 entries for one data connection which I use for some dataflows. I deleted the one connected to a gateway. Then I refreshed the report in Power BI Desktop and republished it. The message now no longer appears.

mohitkumawat
Resolver I
Resolver I

here's a more concise breakdown of the steps to address the issue with your Power BI report:

  1. Check and ensure correct data source connections, including credentials.

  2. Verify and update the on-premises data gateway settings for the SQL Server.

  3. Validate and update the connection to the Google Sheets source.

  4. Confirm cloud data sources in the dataset settings and ensure they are correctly connected.

  5. Ensure the on-premises data gateway is running and accessible; consider restarting it.

  6. Attempt to publish the report again after addressing any issues with connections and settings.

  7. Check workspace settings for any restrictions or configurations causing the issue.

  8. If the problem persists, create a new workspace and attempt to publish the report there to isolate the issue.

What if the source is only an excel file on Sharepoint.?

I receive an error while publishing that the file was published but disconnected.

To correct this.. I created a gateway on my laptop and assigned it to the report. However, the gateway doesnot seem to work as the data is not refreshed on the dashboard when I refresh my source excel file.

collinq
Super User
Super User

Hi @G_CR_23 ,

 

I have noticed this and think it is a bit of a misleading message.  I think this appears the first publish (or subsequent one) when the settings of the report do not have the Data Source already connected.  So, it kind of happens on the first publish of any report that requires a data source - because you can't go into the settings to assign the data source UNTIL you have published!

This message has always cleared up for me after I set the Data Source in the settings in the service.

 

As for the message about the cloud settings error - did that go away once you set the gateway/data source?  It normally goes away for me at that point....




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Hi, @collinq !

Thanks a lot for the answer!

I try to explain better.

I had built a report (properly working), connected to two power bi datasets (properly configured, connected to gateway, data updated regularly, and so on).

For several reasons, I had to remove one of the two power bi datasets, and add a direct data source (basically I imported the data from one of the two power bi datasets, instead of connecting to the dataset). I specify that the imported data has the same origin as the power bi dataset (same db, same server, it's exactly them). So this data source is already configured with the gateway correctly.

Once I did this, the error "One or more cloud data sources for this dataset have been deleted" appeared in the dataset settings. I state that I removed all the data sources that are no longer needed also from the local file before publishing.
This message made it impossible for me to update the data, because it didn't allow me to select the existing gateway. It also asked me to choose a mapping for google sheets as well (which don't need gateways). I've been trying to fix it for days, with no success. So I tried to build the report from zero, assuming a bug.

I created a new pbi file, connected to a power bi data set and to the server directly (I specify that this is not the first time I have done this, there are other reports that work correctly).
When I publish the report locally on the service, I get the error "Your file was published but disconnected" with the same problems described above. Inability to update data, schedule update, select gateway. everything is blocked.

Sorry if I wrote a lot, but I tried to explain better.

Thank you!

Hi @G_CR_23 ,

 

Have you tried to publish your newly built report with a different name to check if the issue will still happen?

Hi @mussaenda ,
yes, i tried it, but nothing happens.

If i remove the power bi dataset, all works fine (with the imported table). Gateway, update, credentials, all work fine.

Sames if i remove the imported table (so, basically a live connection to the pbi dataset).

But if i combine them together i got the messages ""One or more cloud data sources for this dataset have been deleted" and "Your file was published but disconnected" and nothing works.

It's really tricky and weird for me

Hey @G_CR_23 ,

 

Thanks for the long explanation!  I have done a bunch of searches and talked with a couple people and don't have a much better/newer answer.  One thing I ran across was to absolutely confirm that the data source settings in the pbix file is the same as the data source in the Service.  I would suspect that this is not your issue but just checking.

 

I think that this might be time to create a ticket.  Please let us know the result if you do create a ticket.




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Pu_De
Frequent Visitor

Hi.. I face the same issue. and that too this has beena recent development. 

The files in the pbix and the service are also the same. Please let me know if there is a solution to this.

Helpful resources

Announcements
PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors