Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
ericg
New Member

Cannot Delete Content Pack

We recently started trying to use Power BI at my company, and in some of my demo'ing I created a content pack for the organization in the web app. This was after starting a Pro Trial (which is still active).

 

If I click "Get Data" and choose "My Organization", the content pack I created shows up there with its logo, and if I click on that it states that it was created by myself and I can connect to it.

 

However, if I attempt to delete it, via the settings-cog, and then choose "View Content Pack" Power BI tells me that I do not have any content packs created. Looking at the pane, it does show me as the user logged in, which matches the creator of the content pack aforementioned.

 

Am I going to the wrong place to delete this pack? Is there a way to confirm that I didn't somehow create a seperate account in creating the data pack that my current account cannot access? I don't think this is the case, but I'd like to rule it out.

 

Any help is appreciated, thanks!

7 REPLIES 7

@ericg Did you publish the Content Pack to a user account that you can access? If so, if you navigate to the Content Pack via "Get Data" My org, click on the content pack and see who the publisher is... I don't have any issues with Content Packs I have created...


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Yeah, that's just it... I am the publisher. When I click on the content pack it shows my name and email address as the publisher. When I click on my portrait to the right of the settings icon, it confirms that I am logged into the same account/email address. Yet, when I try to view my content packs, it tells me I do not have any. I thought maybe it's a cached icon somehow? Maybe I'm just still seeing it in my organizational library... but when I asked a co-worker to try the same process of getting data, they are still able to see it as well, and again it lists me as the publisher.

wonga
Continued Contributor
Continued Contributor

I just tried it out on my end and it seems to work just fine in terms of creating and deleting an organizational content pack. Have you tried logging out and back in to the Power BI service? Might be a cache issue or something with your browser. Also try different browsers too.

No go on this either. I signed out of Office 365 / Power BI, cleared my cache, changed from Chrome to IE 11 (and cleared my cache there also) and still am having the same issue.

 

One added detail, that I'm not sure will relate, is that in my original process, I had created a group for my organization, then created the Content Pack. The things I did after that involved deleting the group first and then attempting to delete the Content Pack. I'm not sure if the order of operations here is bad possibly, or if the content pack would even be associated with the deleted group at all. That said, the group was deleted just fine.

@ericg Did you create the Content Pack from within the Group?


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

My guess is that I did create the Content Pack from within the Group. This was a couple of weeks ago, so I don't remember exactly the timing of everything I initially did. I do strangely have a dashboard under dashboards that is listed when I select "Show: My Content" but when I click on the elipsis next to it is stated to be owned by the group I created and then deleted.

 

In any event, I cannot find any evidence of that group existing (aside from owning one dashboard that I can still see) in either Power BI or Office 365.

@ericg Yeah, this is a really kludgy bug. The "guts" of a Group are not deleted when you delete the Group. You have to make sure that all datasources, reports, dashboards, (and now apparently Content Packs) are deleted prior to deleting the Group. i've seen the shared elements sticking around, so it would only make sense that the Content Pack sticks around as well... I don't recall if I filed a bug on this particular item or not.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Helpful resources

Announcements
Fabcon_Europe_Social_Bogo

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors