Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
mark_endicott
Solution Specialist
Solution Specialist

An incompatible filter is used on a column with a parameter mapping.

Hello, 

 

I set up a Dynamic M Query Parameter and bound it to a field in one of my dimensions. Since doing this I received the following error on some of my visuals: "An incompatible filter is used on a column with a parameter mapping." The filter is a TopN. - I did not see any warning for this in the MS Documentation. 

 

I am still getting this error after I have:

 

1) Un-bound the parameter from the column, published & fully processed the table using the XMLA endpoint

2) Deleted the parameter published & fully processed the table using the XMLA endpoint

 

So there must be some metadata attached to the column that I cannot see, nor remove. 

 

Is there any way to fix this, without deleting the column and adding it to the dimension again?

Is this a bug that MS should be aware of?

 

Thanks, 

Mark

 

7 REPLIES 7
mneff14
Regular Visitor

@mark_endicott Not sure if this is still an open issue, but for future readers, the documentation does specify that TopN is one of the filters that are NOT supported with Dynamic M Query Parameters. 🙁

 

Dynamic M query parameters in Power BI Desktop - Power BI | Microsoft Learn

 

mneff14_0-1677509833826.png

 

Issue was resolved, problem was not that I had tried to do something that was not supported, more that I needed to undo it and Power BI was allowing it.

Microsoft accepted it as a bug and fixed it, but not before I'd used some unsupported features in Tabular Editor to fully remove the metadata from the columns. 

what??  I have same error - rpeorting a filter and no filter present

 

Was this issue resolved? I am getting the same error. I have two M parameters, both text, bound to two different columns from different dimension tables. When I use the columns as slicers, I get the same error on one of the slicers. 

 

What is the solution?

Resolved this. I had the slicer filtering "is not blank", which is not supported by M parameter. Removing the filter solved the issue.

v-rongtiep-msft
Community Support
Community Support

Hi @mark_endicott ,

I cannot reproduce the error. Could you please provide more details? At what point did this error occur? After you wet th parameters? What is the type of the parameters?

 

We suggest you to open a ticket here for help if you are a pro user: https://powerbi.microsoft.com/en-us/support/

 

support ticket.gif

 

Best Regards

Community Support Team _ Polly

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-rongtiep-msft it is a text parameter created in Power Query.

 

I used "Bind to parameter" on a column to create a Dynamic M Query parameter according to your documentation. Except I used a column that had a TopN filter set up on the filter pane. When I published the data model to the server the error "An incompatible filter is used on a column with a parameter mapping." appeard. 

 

So I then went back to the column and set "Bind to Parameter" to none and republished the model, I still receive the same error. 

 

So I then went back to power query and deleted the parameter and republished the mode, I still receive the same error. 

 

I have looked at your Support page, and there is no suitable category to raise this issue. Please can you suggest one.

 

Thanks, 

Mark

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.