Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
AdamF
Helper I
Helper I

PBIRS Aug Preview: Comment attachments not loading

Using the Aug Preview version of Power BI Report Server, when a user uploads an attachment to a comment on a Power BI report and submits the comment, the attachment is not accessible. For images, the image does not properly show in the comment. Clicking on the link for the attachment gives 404 error, e.g.:

 

Server Error in '/Reports' Application.


The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /reports/api/v2.0/catalogitems(21138c69-555e-4ed8-b404-a9e74e9bee6f)/Content/$value

3 REPLIES 3
v-yulgu-msft
Employee
Employee

Hi @AdamF,

 

As shown in below screenshot, not all files are supported by attachment file. What file did you uploaded that caused such an error message?

B06B0E9B.PNG

 

In my test, the attached image shows properly.

22272C82.PNG

 

In your scenario, please restart the Power BI Report Server service for a try.

 

Best regards,
Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks @v-yulgu-msft.

 

I've uploaded png and pdf files, both which have the issue.

 

I tried restarting the service, but I still get the same issue.

 

However, I have a separate server with the same version of Report Server, and I tried there and it is working fine. Not sure why it isn't working for just the one instance.

Hello,

 

I have the same issue on the Power BI Report Server (GA - June 2017).

The sever has been configured to change virtual directory on Web Portal URL. Consequently URL is the following :

http://servername:80/reports_XXX (previously http://servername:80/reports)

 

Attachments are accessed from the URL :

http://servername/reports/api/v2.0.catalogitems(<ID>)/Content/$Value

instead of http://servername/reports_XXX/api/v2.0.catalogitems(<ID>)/Content/$Value

 

Can you tell me if we are faced to a bug (hard coded URL)  ?

 

Kind regards,

Yann

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.