Forum Discussion

Emelie20's avatar
Emelie20
Frequent Visitor
4 years ago

importing query from Azure Data Explorer to PowerBI

Hi all,

I am trying to import K queries in Azure Data Explorer to PowerBI. When I copy and the queries inot Advanced Editor in PowerBI. I get the error code: Token Comma Expected

 

The part in red below is highlighted as where a comma is needed. I have chaned it to a comma, but the error jumps to the next (:)

 

I need help on how to clear the error and to use the queries in PowerBI.

 

I have the query as below:

 

let MTNList = externaldata
(Oveid string,vendor:string,product:string,EtinName:string,dateAdded:string,description:string,action:string,dueDate:string,notes:stri
ng) [@https://www.mtd.com/sites/default/files/csv/people_isages.csv\] with (format="csv", ignoreFirstRecord=True)

 

let MTNOveid = MTNList
| project Oveid;DeviceTvmSoftwareVulnerabilities
| where OveId in (MTNOveid)
| summarize Devices = dcount(DeviceId) by OveId
| sort by Devices desc

 

 

Thanks

2 Replies