Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
MJ
Frequent Visitor

Scheduled Refresh not working (working with only one dataset)

Hi everyone,

I have this issue:
I have several PowerBi Reports with their data sets.  There is the latest PowerBI on premise gateway installed on my server and the latest PowerBI desktop application. When I go to DataSets settings and try to schedule a refresh I get the message saying "No gateways installed or configured for this dataset."

 

So, the problem is thata the gateway is installed and configuread and running without problems. With one dataset I can schedule refresh and it's working.

Is there anything I can do?

pbi2.jpgpbi1.PNG

As you can se on my first photo, it is saying that i have no gateway installed but on the 2. it is working.

 

Thanks

Marko

1 ACCEPTED SOLUTION
v-yuezhe-msft
Microsoft Employee
Microsoft Employee

@MJ,

Does your dataset contain multiple data sources? If so, please add all the data sources of this dataset within gateway. In addition, please make sure the connection strings you use in gateway match the connection strings in Desktop.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
v-yuezhe-msft
Microsoft Employee
Microsoft Employee

@MJ,

Does your dataset contain multiple data sources? If so, please add all the data sources of this dataset within gateway. In addition, please make sure the connection strings you use in gateway match the connection strings in Desktop.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yes, thank you.

I've read about multiple sources, but in my case I had some excel files not used on all datasets. So I thought that dataset which didn't use excel files should work.

Now I've added the folder with all the files as a new Data origin and it is working well.

Thank you.

Regards

Marko

troyel
Advocate II
Advocate II

I am having the same problem. This used to work for me before two things happened:

1. I updated to the newest May gateway version and

2. I changed the ownership of the report being refreshed (to someone else who was also admin to the gateway).

Now the previous and the new owner can't refresh through the gateway (the old published files with exact same source seem to still be working, though). 

 

Seems like a bug to me? Is it possible to downgrade the enterprise gateway to test if it is a May issue bug?

 

Thanks!

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors
Top Kudoed Authors