Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
gbrown05
Regular Visitor

Salesforce Disabling TLS 1.0 -- Power BI Connections

Hi All,

 

Salesforce is disabling TLS 1.0 in early 2017. Power BI connects to Salesforce using TLS 1.0. Is there a plan to upgrade the Salesforce connector (Reports + Objects) to use TLS 1.1/1.2? Otherwise, my understanding is that the Salesforce connectors won't work after March 4, 2017.

 

On all of my Salesforce orgs' login logs, I see that all Power BI connections using TLS 1.0. However, I am also able to connect to a sandbox, which supposedly had TLS 1.0 disabled in June -- so it may be possible that the logs are incorrect and the connector actually uses TLS 1.1+?

 

Thanks!

5 REPLIES 5
jaschro
Frequent Visitor

This issue is marked as "Solved" but I can't tell what the solution is.  I have several PBI pbix files which I publish to Service and refresh from there.  How do I tell whether they're using TLS 1.0 or TLS 1.1? 

Hi jaschro,

 

I was also disappointed when it was marked solved because the solution isn't clear. Either there's a problem with Salesforce logs, or Power BI is still using TLS 1.0. The reason I don't think it's the latter is because I can connect to an org that has TLS 1.0 disabled. Still, it would be helpful if folks from Microsoft or Salesforce could jump in to clarify why connections from Power BI show up as using TLS 1.0 in all the logs.

 

I just reopened this question.

 

George

 

 

Agreed.  In my case, I admit that I can't even spell TLS.  I certainly don't know what it means or what to do about it.  From the prior statements in this thread, it seems like the TLS issue will take care of itself with Salesforce.  But I'm not sure if that's actually true.  And I certainly don't know how to tell which I'm using.

v-yuezhe-msft
Employee
Employee

Hi @gbrown05,

As stated in this blog, when Salesforce disable TLS 1.0, users who use Connect for Office are strongly encouraged to transition to Microsoft Power BI as an alternative. It indicates that Power BI supports to connect to Salesforce using TLS 1.1.

In addition, according to the above blog, as of June 25 2016, Sandbox instances no longer allow for TLS 1.0 access, and in March 2017, production will no longer allow for TLS 1.0 access. Thus, if you connect to Production org, it still use TLS 1.0 now.


Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for your response, Lydia! I guess I am just confused by the (sandbox) logs showing TLS 1.0 for Power BI logins, even in sandboxes that no longer accept requests over TLS 1.0.

 

Looks like everything should be fine from Power BI.

 

 

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors