Rose__123's avatar
Rose__123
Icon for Helper II rankHelper II
4 years ago
Status:
Investigating

Seemingly random error: An existing connection was forcibly closed by the remote host

Hi

I have a dataset consisting of data sources from Power BI flow, Microsoft Business Central 365, Microsoft Ondrive, and a single webpage. Recently, Business Central made an update, that forced me to change my sources from Web Services to Advanced APIs in Power BI.


Then I started to get this new error online: OData: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.. The exception was raised by the IDataReader interface. Please review the error message and provider documentation for further information and corrective action.

 

I found that I wasn't able to update the data on my desktop either, except if I removed a merge between a large table from an Advanced API with a smaller table from a Standard API v 2.0. It didn't matter if I made my dataset small - if I had the merge it did not work (it did work before the Business Central update). 

Now I have removed the merge, and most of the time I am able to update the data on my Desktop, however online it seems random if I can make the update:

 

Data source error:OData: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.. The exception was raised by the IDataReader interface. Please review the error message and provider documentation for further information and corrective action.
Cluster URI:WABI-WEST-EUROPE-E-PRIMARY-redirect.analysis.windows.net
Activity ID:0e9ee190-9a21-4a03-b519-f15519792ed9
Request ID:e5cda8b8-83f8-49b8-b30b-00d4336b0b62
Time:2022-05-11 23:42:18Z

 

Why? And why can't I suddenly make the merge between the tables? They are the same as before, the only change is their source (and the Advanced APIs should be faster than the Web Services I was told).

 

Best Regards

 

3 Comments

  • v-cazheng-msft's avatar
    v-cazheng-msft
    Icon for Community Support rankCommunity Support
    Status changed:
    New
    to
    Investigating

    Hi Rose__123,

     

    May I know whether you have PPU capacity or Premium capacity? If you have one of these capacities, could you please try to move the report workspace to that capacity to see whether the failures will reduce with more resources?

     

    In addition, please try to prolong timeout as well.

    Solved: Unable to read data from the transport connection ... - Microsoft Power BI Community

     

    Best Regards,

    Community Support Team _ Caiyun

  • Hi v-cazheng-msft 

    I tried to move it to a Premium Per User workspace.

     

    It has made fewer errors than in the other workspace, but it did make one error. I did not change the timeout yet. But why do you think that it suddenly is a problem? It made the same error when I made my dataset a lot smaller and I never had the error before the Microsoft Business Central update. 

     

     

  • We encountered the same issue and reduced the maximum number of items per page in the Business Central connector, which resolved the problem on our side -> Dynamics365BusinessCentral.ApiContentsWithOptions(null, null, null, [UseReadOnlyReplica=null, AcceptLanguage=null, Timeout=#duration(1, 0, 0, 0), ODataMaxPageSize=50])