Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

0

Open hyperlink problem (open is OK, but missing reserved char " : " when open the internet browser)

When I open the hyperlink (1) it's opening chrome correctly,
but It's missing ":" comma char, so I have to type ":" comma char manually in the browser to open the
folder that I need. Who can help me to say why I am doing wrong? How can I solve this issue?

I read some articles and I saw the ":" comma char is an URL Encode and it corresponds at "%3A", it's reserved. I still don't know how to solve this issue I have already tried to change the hyperlink from "http://file://...." to "http://file%3A//....", but if I do this the hyperlink does not work as a hyperlink at Power BI and does not open the web browser. Somebody can help me? I appreciate it a lot and need too much help with this issue.

Link Problem - Forum.png

Status: Delivered

Hi @Janaam,

 

Power BI won’t make any modifications to the web urls imported into it for they are text type data imported into Power BI. As you can see, here is a web url containing “:” and  it works well when clicking on the link. (Test with Chrome and Microsoft Edge)

vcazhengmsft_0-1651546394774.png

 

vcazhengmsft_1-1651546394777.png

 

This issue is caused by how the browser parse the URL. If input a url like http://file://test.html, it will be handled as the second screenshot showed.

vcazhengmsft_2-1651546394778.png

 

vcazhengmsft_3-1651546394778.png

 

Best Regards,

Community Support Team _ Caiyun

Comments
v-cazheng-msft
Community Support
Status changed to: Delivered

Hi @Janaam,

 

Power BI won’t make any modifications to the web urls imported into it for they are text type data imported into Power BI. As you can see, here is a web url containing “:” and  it works well when clicking on the link. (Test with Chrome and Microsoft Edge)

vcazhengmsft_0-1651546394774.png

 

vcazhengmsft_1-1651546394777.png

 

This issue is caused by how the browser parse the URL. If input a url like http://file://test.html, it will be handled as the second screenshot showed.

vcazhengmsft_2-1651546394778.png

 

vcazhengmsft_3-1651546394778.png

 

Best Regards,

Community Support Team _ Caiyun

Janaam
Frequent Visitor

Hi @v-cazheng-msft.

First of all I would like say thanks a lot for your attention. 

But is there any solution for my example?

Is there any change that I can configure at chrome or the internet explorer browser to not discard ":" chars?

I really sorry but I didn't understand if there is or not a solution for my problem.

Just to try to pass more information check bellow:

1 - OK

http://file://brhor1fls1/me-producao_EOL$/Defect1.png

2 - KO

http://file//brhor1fls1/me-producao_EOL$/Defect1.png

Just to remember, when I click on situation "1 - OK" at Power BI, it's open the web browser and show situation "2 - KO". So the file doesn't open because remove the ":". Just open if I type manually the char ":" after "file" string.

 

Tks again!

Janaam🙌