Lorelai's avatar
Lorelai
Frequent Visitor
2 years ago
Status:
Accepted

Fabric Capacity Metrics not showing data

We've been following this blog (https://blog.fabric.microsoft.com/en-us/blog/capacity-metrics-in-microsoft-fabric) in order to study the capacity and the consumption being used in the fabric trial that we've enabled. However, when we get to the end, we're not seeing any data in Power BI but this error message: "[ccon]Internal Error: Error obtaining data location. [/ccon]. The exception was raised by the IDbCommand interface."

 

Error in Fabric Capacity Metrics

 

Does anyone know how to fix this?

 

Thanks in advance.

7 Comments

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi  Lorelai 

    It’s a known issue. The engineers are actively working on this issue and I will come back with an update if there is any progress.

     

    Best Regards,
    Community Support Team _ Ailsa Tao

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi  Lorelai 

    This issue has been fixed , please check it in your Metrics .

     

    Best Regards,
    Community Support Team _ Ailsa Tao

  • BethR's avatar
    BethR
    Regular Visitor

    Hi Lorelai ,

    I'm still having this issue, except it's with our paid Fabric Capacity - not the trial. 

    It started last week around Thanksgiving.

    Do you know if they're still working on this?

  • Element115's avatar
    Element115
    Icon for Memorable Member rankMemorable Member

    Anonymous I just uninstalled the Fabric Capacity Metrics, then re-installed it.  Now I get this error message--What's the solution?

     

  • I'm having the same issue for both my trial capacity and my paid capacity, has anyone solved this? (i've uninstalled and re-installed two days in a row, 2 times.) I tried playing with the parameters in the refresh section a bit to see if that would fix it but no luck.

  • I was using the subscription ID of the capacity(from azure portal) instead of the Capacity ID of the capacity (get this from the admin center in fabric). Once I corrected that parameter it worked.

  • If it helps anyone else... It's the GUID that looks like this Axxxxx5B-Cxxx-4B0t-8D92-489D2xxx2B6B (redacted).

     

    In the Admin portal, go to Capacity Settings, then click on the name of the Trial capacity, or whatever other capacity name can be clicked on.

     

    You'll then see options like Capacity Usage Report, Notifications, etc.  There's a gear on the right side of the page, click that.

     

    You'll then see the Settings tab, will show a list of people under the Service Admin, you're username should be there.

     

    Then at the bottom of this tab it will say SKU, Region, and Capacity ID. 

     

    Copy the Capacity ID GUID, looks like this Axxxxx5B-Cxxx-4B0t-8D92-489D2xxx2B6B (redacted), and then paste that in the setup of the Capactity Metrics app.

     

    After a few failed attempts, changing parameters, etc. I Removed the entire Workspace and then added the Metrics App anew.