Azure Data Explorer: An existing connection was forcibly closed by the remote host
My Power BI report has been refreshing for a few weeks through an Azure Data Explorer query without issue. Recently we have been unable to refresh on schedule or manual retries due to this following issue:
Something went wrong
There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.
Message: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. Table: IndexFragmentation.
Cluster URI: DF-MSIT-SCUS-redirect.analysis.windows.net
Activity ID: 1edb1448-827e-45c8-a181-1c38ff6c3624
Request ID: 0e2c5820-8e33-6929-ff81-e5596e0e5971
Time: 2020-02-12 22:17:06Z
The connection is just fine when I refresh through Power BI Desktop and can then publish the refreshed report, but that is not a maintainable workaround. I have no idea how to diagnose this issue. Any help is appreciated.
2 Comments
- sarabelt
Microsoft Employee
It turns out the report was edited online, but originally built in Power BI desktop. It seems like the online editing broke the refresh. Is this the expected behaviour?
- v-chuncz-msft
Community Support