Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
thomaskelly
Helper I
Helper I

Unable to "Apply Query Changes".

Hello,

 

I merged two tables from a MySql connection in power query, however when i go to apply these changes the process times out and only reaches 6335 lines out of 800,000+ so a long way to go.

 

I have devloped the dashboard before using the same data from the MYsql connection but downloaded into Csv files and the merge and updating worked fine, however I now want to remove thi setp and have a direct link.   When i remove the merge step the data refreshes fine.

 

Any suggestions would be most welcome.

 

Many Thanks

 

Tom

1 ACCEPTED SOLUTION

Hi Lydia

 

I have rebuilt the data set from the ground up starting with all of the tables from one Sql server then making changes to these before introduction the tables from another sql server.

 

This seems to have fixed the issue, and the report is refreshing in minutes when before just making one change in the query was taking hours to update.

 

Thanks for you help and comments 🙂

 

Kind Regards

 

Thomas

View solution in original post

12 REPLIES 12
Anonymous
Not applicable

I have seen this in Oracle too. The problem was that the data type in the columns I merged were different types. When I changed the data types in theese columns to the same (Number) then the merge went may times faster.

 

Regards
Aslak

Anonymous
Not applicable

I apologize if this is repetitive (I am not a developer/programmer - a wannabe).  This question seems similar to mine, but my error was the result of creating a query with multiple excel files (FY11-FY19) in a folder.  Can you explain what the issue is and how I can fix it?

 

 

unabletoapplyquerychanges.png

check that the tabs are consistent in their naming convention in each workbook AND that it's what it was named when you intially set it up. othewise, open your navigation steps and make corrections

v-yuezhe-msft
Employee
Employee

Hi @thomaskelly,

Specify appropriate value in “Command timeout in minutes (optional)" following steps below, then check if you can refresh successfully in Power BI Desktop.

1. Click on the arrow for "Edit Queries" in your current Power BI Desktop file, select "Data Source Settings” in the dropdown.
2. Click on "Change Source..." in the Data source settings pop-up window.
3. Click on Advanced Options in the pop-up window, enter 60 minutes in the "Command timeout in minutes (optional)" textbox, then click OK.

Alternatively, you can directly add CommandTimeout in Advanced Editor as shown in the following screenshot.
1.PNG

 

Thanks,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Lydia

 

Thanks for this. I have tried and it has increased the timeout but not solved the issue.

 

I am connecting to a MY SQL connection the merge itself is ok , when try to expand the column's the process slows to a near halt.  But using the same data in CSV files is not a problem.

 

I am perplexed!!

 

Kind Regards

 

Thomas

Hi @thomaskelly,

Do you use 32bit or 64bit Power BI Desktop? What is the timeout value you specify? Is there any possiblity that you import restricted columns and rows from MySQL to Power BI Desktop?

Regards,
Lydia Zhang

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi

 

Using a 64bit version , I have set the timeout at 8 hours and there are no restricted columns ... I have cut everything back and still no luck....

 

Kind regards

 

Thomas

@thomaskelly,

I would recommend you check that if you can increase query timeout or connection timeout value on MySQL server side.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Lydia

 

I have rebuilt the data set from the ground up starting with all of the tables from one Sql server then making changes to these before introduction the tables from another sql server.

 

This seems to have fixed the issue, and the report is refreshing in minutes when before just making one change in the query was taking hours to update.

 

Thanks for you help and comments 🙂

 

Kind Regards

 

Thomas

are you loading more than one query at once?  

 

i know in the past when i have changed this setting it has helped  - untick the paralell loading

 

Capture.PNG

 





If I took the time to answer your question and I came up with a solution, please mark my post as a solution and /or give kudos freely for the effort 🙂 Thank you!

Proud to be a Super User!




Hi ,

 

I have changed the data load settings and un- ticked the load to report option on all but one of the query's, the remaining query has one column name change and one move column change. When I try to apply these changes to this one table I have the following running in the background.

 

2 x cefsharp.browsersubprocess.exe using 300mb of memory

4x microsoft.mashup.container.netfx40.exe using 400mb of memory

1 x power bi 300mb of memory.

 

this is a lot of resources for just one table effectively an done change ?

 

Kind Regards

Tom

thomaskelly
Helper I
Helper I

The error message is shown below.

Untitled.jpg

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.