Showing results for 
Search instead for 
Did you mean: 
Not applicable

Unable to Connect to MySQL database

I tried to connect to MySQL database. It gives the following error. Any help please?


When I select to SQL

Error Screenshot.JPG


Details: "An error happened while reading data from the provider: 'Could not load file or assembly 'Renci.SshNet, Version=2016.1.0.0, Culture=neutral, PublicKeyToken=1cee9f8bde3db106' or one of its dependencies. The system cannot find the file specified.'"


Solve with previous version of connector.


Thanks !!!

View solution in original post

Frequent Visitor

fixed by uninstalling current connector and installing mysql-connector-net-6.10.7.msi

Not applicable

This is so frustrating. I've spoken to PowerBI support and they couldn't help either. Main points:


Trying to connect to MySQL DB secured via SSL

This worked earlier in the year


Something changed (no idea what) and now I get an authenticartion error whenever I click login.


Things I've tried:

Reinstalling PowerBI

Installing versions 8.0.14, .15. 16 .17 and .18 of MySQL Connector

Using another computer

Adding certs to the computer cert store (Personal, Truster Root, Third party)

Removing everything and starting again


To prove it is something to do with the certs I've also asked the DB admin to remove them and this allowed me to connects immediately using username and password only


To prove the certs are okay I can connect to the DB from my maching using MySQL workbench. Interestingly you actully point to the cert pem files in the Workbench login screen. I also spoke to Tableau about this and their support were able to help me connect using the same certs with no issues.


Please, please, please can someone help. 

Not applicable

Aaah I feel like I'm going a little crazy. So I followed the advice below and donwgraded to an earlier Connector version (8.016 I think) and it cleared this error and I was able to connect fine for a few weeks. I was recently experimenting with another BI tool and needed 8.0.17 so upgraded again. To use PowerBI I downgraded again this week and now whenever I try to connect I just get 'We couldn't authenticate with the credentials provided' message. I've tried 8.0.15, 8.0.16, different user names and passwords and still have the same. Credentials are fine as when I connect via MySQL Workbench it connects okay. Any ideas?

Not applicable



I solved this problem by uninstalling the latest version of MySQL Connector (8.0.17) and installing the 8.0.15. I followed this video :


And this is the link to download the version 8.0.15 :


Good luck you all.

Not applicable

Thank you! 8.0.16 fixes my issues as well!


I also downloaded it from this link:

Advocate IV
Advocate IV



New Member



I have fixed that issue by using an older version fo the mysql-connector...

Here a link that I will share for some time: mysql-connector-net-8.0.12 (x64)

Hope that will help some of you 🙂



Not applicable

Thanks) Its working Smiley Happy

Not applicable

I had the same problem, but it emerged from wanting to install the latest version of the Mysql Connector (mysql-connector-net-8.0.17).


Once installed, the problem started.


I rolled back to the previous version of the connector that I had installed (mysql-connector-net-6.10.8).


Problem solved.

Not applicable

I had the same problem with 8.0.17. I uninstalled it, and installed 8.0.16 from here: . Error went away. 


Am using the sqlconnector 8.0.16 but still am facing the same error , could you please help ASAP.



Suresh .

Hi @SureshPantra, as everyone has been starting throughout the thread, please install 8.0.15 !
I have just done it 2 minutes ago and it has worked for me.
Not applicable

Perfect. This worked for me too.

Can confirm, it doesn't work with 8.0.17 but does work with 8.0.16: (tested with PBIRS-January version, if that matters).

Solve with previous version of connector.


Thanks !!!

I had a different error "call to SSPI failed". Installing version 8.0.16 of connector also solved my problem. Current version today is 8.0.28. Also, restarted my computer after reinstalling.

Not applicable



i have downloaded and installed 8.0.16, but still it shows 8.0.17 in start menu.


How do i check whether it is 8.0.16 in MySQL?


i belive folder name is 8.0.17 but it has changed.


please let me know if you have any suggestion or solution for it.

Hi Nagesh,

Try uninstalling all MySQL components (if you don´t you use MySQL), then just install that connector and give it another try. It should work. I recently swipe my hard drive with a Solid States and did the same process the it worked. Please let me know how it goes. Also I can help you thru Teamviewer.

Not applicable



Should i uninstall entir MYSQL and reinstall it again, if so can you give me the link of 8.0.16.


If i install that, will i automatically get MYSQL Workbench?


Thanks in advance:)

Helpful resources

PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Top Solution Authors