Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

New Member

Thousand Separator and Decimal Separator

Hi!!! I'm writing from Spain. I'm having problems with decimal separator and thousand separator. Here in Spain, decimal separator is a comma and thousand separator is a point. But PowerBi goes wrong, (decimal separator = point and thousand separator = comma). The regional configurator is correct and Excel configurator is correct too. What Can I do? Can anybody help me? Thank's a lot!




@Natxo The screenshot looks correct to me, the thousands separator is "." and decimal is ","


What are you expecting?

View solution in original post

Memorable Member
Memorable Member

I am facing the same problem. Fortunately is a known issue and they are working on it..check this thread
Konstantinos Ioannou

Hi Konstantinos!!! Sorry for that. I did not see your post about this issue. I am downloading the last version and...Let's see. 🙂 

@konstantinos@Natxo Today we released a QFE on the Jan update that should address this issue. Can you download the latest bits and try again?

@pqian Great is working..Thanks for the fast patch.. The advanced download link page still hasn't the latest one. 

Question: regarding the service are we expecting an update also? or we need to do some action ? Upload or refresh the pbix reports don't work..



Konstantinos Ioannou

 @konstantinos Are you using Chrome to browse the service? Does the problem also repro in IE as well?


The service picks up the browser language and regional settings. In IE it's the system one, in Chrome they have a separate settings for it, you may have it set to English?

@pqian  The issue in Service still exists. 


I live in Netherlands but unfortunately I don't speak Dutch , even if I did for display language  I always use English language.


So the windows dispaly language is and was in English (US).


The service before January was showing correct the delimiters for Europe/Netherlands, I didn't change any settings ( only after the problem to trying to fix the delimiter display and then set it back to the settings I had before)


Let's start:

My workstation laptop / OS version :  Windows 10 Home -  1511 build 10586.104 















I use Chrome mostly but the issue appears in all browsers.  screenshot below , The language is English Canada due to playing aroung with all Engish Language packs. The same occurs with English US and English United Kingdom.

As you notice PowerBI desktop is fixed ( yeahh) due to latest version download.





You might suppose that  English language is the problem.. Wrong..I change settings to Greek display language ( I am Greek and the delimiters are same as Netherlands and most of Europe ).






As you might notice chrome has his own settings. Let's try to change it also in Greek.... Interesting , chrome display menu etc in Greek but PowerBI service uses the Settings from Display language. ( Was set back to English US) ..



Before you say that I mixed up settings or a problem with my laptop...I used the laptop of a Dutch user.


User laptop = Windows 10 home 


5 (1).png




Now open PowerBI service in Internet Explorer and Chrome.. Regional settings in Netherlands and Display language Dutch. Not even installed another language pack. 

The same delimiter error..


6 (1).png



Unless I missing something ( might be the case )   it seems to me that there is an problem how PowerBI service reads internet explorer display language or an win 10 update mixed things up..


Hope the above helps..


P.S. If is in your knowledge please advice which English language should be use. But of course many users are affected that using English US instead of Dutch and is not possible for everyone to swith languages specially because was working previous months.





Konstantinos Ioannou



I was informed by MS support ( Brad )  that a fix was pushed to production.


I can confirm that for Dutch/Greek ( probably all ) language the decimal is showing/ reading settings correct on Edge & IE.( not in Chrome )


Unfortunately for me when the display language is English, tried almost all combinations of English & Region, I couldn't find a setting that display English and the correct decimal mark ( comma ) and respects the number format settings.


I would greately appreciate if you or anyone on the community has it working and share the settings. 


Thanks for the quick fix, my users are really happy again

Konstantinos Ioannou

@konstantinos Have you tried Chrome's language settings? You'll have to make sure Dutch is the first one of the group. Restart and try again.

@pqian I tried language settings in Chrome didn't work..probably needs to change account setting language ( I will try it )..But my issue is that I need English language to be first / display in all browsers..since this is what I use to work & demo.


Any suggestions for English and decimal comma?

Konstantinos Ioannou

@konstantinos try adding a language=xx at the end of the query string. For example:



This setting depends on the deployment and may or may not be available on your cluster. It also changes the locallization settings. Unfortunately I don't think Globalization can be configed differently from your locale. So I don't think there's an English setting that uses , decimals (to be an English speaker, this could be very confusing. So if you are presenting to English audience, sticking to . is probably the better choice)

Thanks @pqian..I will try it.


Unfortunately my English audience is Dutch, Greeks , Danish, etc that we all use comma as decimal but English to communicate.


Before January I was able to use English & comma as decimal (always used English as Display language )  that is why I also saw the change to dot and post the issue.


So probably I will give up my hopes to use it again!!


Thanks for all the work and info

Konstantinos Ioannou

@konstantinos You made a good point, I think Globalization settings and Localization settings should indeed be separated. Don't give up hope yet, I'll contact the team behind this.

@pqian Truth is I never give up hope with PowerBI Team!!Smiley Happy Thanks

Konstantinos Ioannou
Not applicable

Here's a dilemma.


Locale settings in Power BI Desktop is in my local language where we have "." for thousand seperator and "," for decimals.


The default setting in Google Chrome is English which means that when I publish reports to the web, locals will see commas where there should be dots and vice versa. 


If I change the language settings in Chrome to my local language as first language, it works fine.

However I shouldn't have to change the settings. The published report should simply use the locale settings from Power BI Desktop


Does anyone have any work-around for this that doesn't require any changes to the browsers in use ?

Hi guys, is this problem again appearing on the new update of Power BI (August 2019)?

@konstantinos Thank you for the investigation. I think I've found the cause. I'll contact the service team to get this addressed ASAP.

Thanks @pqian , glad that helped to spot the issue...
Waiting your update.
Konstantinos Ioannou

@pqian@konstantinos Hi! Is this th last version? Last-Version.png

I have the same problem after install that version. Are there newer? Thanks!!!!



@Natxo The screenshot looks correct to me, the thousands separator is "." and decimal is ","


What are you expecting?

@pqian Yes...I need to go to an optician...Sorry. It's correct. Perfect! Thank you very much!!!!

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors