Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
davehus
Memorable Member
Memorable Member

The model doesn't have a named expression named

Hi, I'm getting an error message that only appears to affect measure tables in my model. When I refresh I get a message The model doesn't have a named expression named. I've never experienced this before and it's only just occurred in the last couple of days.

 

What would be the reason for this, does anyone know?

 

Thanks 🙂

1 ACCEPTED SOLUTION
CheenuSing
Community Champion
Community Champion

Hi @davehus ,

 

Have you checked

 

https://community.powerbi.com/t5/Issues/Error-message-quot-quot-The-model-doesn-t-have-a-named/idi-p...

 

It may help

 

Cheers

 

CheenuSing

Did I answer your question? Mark my post as a solution and also give KUDOS !

Proud to be a Datanaut!

View solution in original post

10 REPLIES 10
CheenuSing
Community Champion
Community Champion

Hi @davehus ,

 

Have you checked

 

https://community.powerbi.com/t5/Issues/Error-message-quot-quot-The-model-doesn-t-have-a-named/idi-p...

 

It may help

 

Cheers

 

CheenuSing

Did I answer your question? Mark my post as a solution and also give KUDOS !

Proud to be a Datanaut!

Hi @CheenuSing ,

 

I renamed the measure tables and this seemed to clear that error. That being said, I don't know if this will repeat though as per @mo_jo_jo 's comment. There has be some sort of bug as this has never happened before and has effected all previous versions of the file.

 

Hopefully it doesn't become a regular occurence.

 

Dave

Hello, The same thing has happened to me and changing the names of the tables of measures to which it refers has been solved, but come on, I hope that in next updates they solve it because it is a little nonsense.

Thank you for sharing your solution

@davehus  Same here. I have had to create new tables and transfer all measures, which for now seems to have resolved the issue. A pain in the a$$ because this was a big model, with close to a 100 measures, grouped into 7 different measure tables. This model just grew and grew to do different things over time. This model in turn feeds 2 other reports which I will have to update later today as all visuals will now be broken. 

 

Not sure why this error happened, but it sucks and I have taken a bit more precaution this time out. 

This time, with the new tables, I have made sure to include at least one empty/standard column within the measure table.

I kept getting an error within Power Query when I tried to disabling the original measure table (containing just measures), stating that the table contained no valid columns and would be prevented from loading into the model. This then resulted in Query changes not being applied (i.e. apply or discard query dialogue appeared and could not be closed out).

 

My thinking now is that it is prudent to have a "valid" column type, even an empty one, within every table. This should ensure at least it will load every time if for some reason we need to check future issues with any table in the model by enabling/disabling load. 

I do not want to be going through this at some random time in the future because something has possibly been changed by Microsoft backstage in the product; just for the sake of a nice looking calculator icon indicating a measure table.

Not worth doing this again on a model this size. 

 

@az38  Thanks for the response and the suggestion.

I had the same problem with my measures table.  I resolved it by doing this:

1.  Go to Transform Data

2.  Select my measures table

3.  Under Add Column, select Index Column > Select from 0 (or 1, doesn't matter)Key Measures Error.JPG

4.  You may get an error that says "The table is empty", but click through that.

5.  Try refreshing your report.

 

This is what worked for me.

 

This worked for me.  

@Roseventura Thanks for sharing that fix. I guess it achieves the same result because it somehow introduces elements that are then recognised within the report "side". Your suggested fix seems much quicker than the reset approach I took 🙂

Glad it worked out!

I also have this error message, which only affects multiple measure tables that I have in my model.

The error message has came out of nowhere for a file that updates on a monthly basis and was being updated today.

Something seems to have broken for measure tables, and seems to affect some Power BI file. This issue affects even the backup copies of the file that I created, which suggests this issue is not limited to just one .pbix file and could be more "a system thing". Frustrating. A 30min exercise update activity has turned into a wasted day. 

 

Thanks for the suggestion @CheenuSing, but the fixes proposed in the thread you suggested haven't helped to fix the problem.

If anyone has more suggestions, please share. 

az38
Community Champion
Community Champion

Hi @mo_jo_jo @davehus 

try to click step by step all applied steps for each data source, it can help you to localize a problem


do not hesitate to give a kudo to useful posts and mark solutions as solution
LinkedIn

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Top Solution Authors