Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Microsoft Employee
Microsoft Employee

Share your thoughts on DirectQuery for Power BI datasets and Azure Analysis Services (preview)

Hit Reply and let us know what you think of the DirectQuery for Power BI datasets and Azure Analysis Services.  To learn more about this feature, please visit this blog post or our documentation.


Here are some areas that we'd like to hear about in particular:

  • Performance
  • Query editor experience--the remote model query doesn't show up in the query editor and only in the data source settings dialog. What are your thoughts?
  • Navigator experience
  • Thoughts around governance and permissions for models that leverage this feature
  • Nesting models, i.e. building a composite model on top of a composite model
  • Automatic page refresh for live connect in composite models

Thanks and we look forward to hearing your feedback!


- The Power BI Modeling Team

533 REPLIES 533

Please provide additional information regarding finding special flags ?


Tried accessing data base directly, same issue
Get Data > SQL Server Analysis Services database > Table Relationships exist
Make Changes to the Model > Table Relationships disappear except one.

you can use any SSAS client tool such as management studio or others to connect to the database. Please check for anything related to private on tables. we have had an issue before where if a table was private it would still be loaded and we have hence fixed it, but wondering if you are experiencing another issue related to it.

Can Microsoft confirm if this is the expected behaviour ?
Workaround after ongoing troubleshooting with user.
Issue related to table key columns being hidden due to Object Level Security being set in Azure SQL Server Analysis Services Database.
Relationships remained after converting from Live Connection to Direct Query when allocated Confidential role access in Azure.
So if a key column has Object level security then all relationships that use that column would be deleted.
Can Microsoft confirm if this is the expected behaviour ?

Regular Visitor



As mentionned in the limitations of the feature, only users that have Build permission on the datasets can see the report/visuals (4th bullet point):


The build permission is not something we necessarly want to grant to any user who wants to consult the «composite» report ... is there any workaround for this limitation?









thanks for the feedback, this is something we're planning to change: just 'read' permissions will be required when we make this feature generally available.

Hi! Do we have any updates regarding the read-only release for using two sets in PRO environments?

we are still waiting on infrastructure changes to happen in the datacenters across the globe before we can make this available to PRO.

Not applicable

Yes! Weird to give changing priviledge to someone would be only reading the dataset outside the original report - a Power BI thin report or in Excel.

Helper I
Helper I


Getting this error in the service after days of developing in desktop with no issue/warning in local refreshes. Very discouraging and wouldn't recommend to anyone to develop in desktop using this feature. I have to now import the datasets I am using instead. I have learned not to use any features in preview going forward if I want to manage expectations well. Preview???? NO THANKS.

I understand that this is annoying - we don't actively stop you from doing this in Desktop as we don't know if you are going to publish to the Service. So instead of "breaking" Desktop for those that never publish to the Service, we allow you to do it and then it breaks when you publish to the Service. If we warned for everything that is not going to work in the Service that would be a very jarring experience and get in the way a lot while it might not even be relevant for you. Please see for a list of limitations in this preview, your exact scenario is listed as well.

Frequent Visitor

It would be great if there were an officially sanctioned and clear approach (or more than one) to managing large datasets (+30GB) using directquery (or not).  This is especially the case because it seems like directquery is currently the best way to deal with huge datasets in PBI. Haven't been able to load huge tables to dataflows, datamart, or blob without timeout errors, etc.  I am fully in the MS ecosystem, so I connect to Azure SQL Database using directquery.  The tables in the DB are indexed (columnstore) and I'm using auto aggregation.  I'm pretty sure that's all I can do (or mostly all), but I'm not entirely sure.  Because it's a little bit of witchcraft.  Would love a video or post like this: dealing with huge datasets from SQL Server et al to PBI. 

This thread isn't related to large models (import or direct query). This is related to connecting to Analysis Services in a Direct Query mode rather than a Live Connection mode.


It looks like there are a number of posts under the desktop section of the sight that maybe helpful:


As a Consultant myself working with large models (primarily against Snowflake), the advice is to import the data into the model in the first place. with large data this requires implementing incremental refresh. (Note that a P1 capacity has a model size limit of 25GB Capacity and SKUs in Power BI embedded analytics - Power BI | Microsoft Docs.)


If you can't scale up the capacity, or reduce data size through optimisation and rationalisation, then utilise direct query with aggregations; auto-aggregations (which may be helpful dependant on the repetitive nature of the queries) or manual aggregations.


There is plenty of material on these topics if you Bing search. GuyInACube has some good material as a starting point:


Regular Visitor

Thanks for adding this feature. Really useful; however we are having some issues at my company. 

As a tenant admin, connecting to a PBI dataset (switched to DirectQuery) + an Excel file is working fine.
But for my colleague (not an admin, but workspace admin), he is getting an error 

"Your credentials could not be authenticated: "Credentials are missing." altough everything is set up correctly in the source (we tried with several kinds). He also enabled the feature in Power BI desktop. 

I checked all the tenant admin settings (mentionned here) too. 
Do you have any idea on what could cause the problem ? 

Thanks for your help

sounds like a permission problem or credentials not being configured for the source. Have you checked the source settings in the Service?

Frequent Visitor

I'm having trouble developing the composite models.
I connect to a powerbi service dataset and create a model in direct query.

I then enabled DirectQuery for PowerBi datasets and the AS option.

Despite this, it doesn't give me the option to connect to any other file.

Also, I went to External Tools and tried to open the Tabular Editor and it gives me an error: The remote server returned an error: (401) Unauthorized

Am I doing something wrong?
Do I need to enable anything else for composite models to work?




not sure. Did you restart Desktop after enabling the preview?

Yes, I did. But nothing happens even though I am connected live to the published dataset.


is this dataset published on Pro/Premium/PPU? Is it not located in "my workspace"?

The report is published with a free account, I do not have a pro or premium.
Also, it is published on my workspace.

from the documentation: "

With another workspace, it just worked, thank you very much

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

Top Solution Authors