Forum Discussion
PowerBI+AWSRDS Postgres18.x .The remote certificate is invalid according to the validation procedure
- 2 months ago
Hello,
Actually, I found the solution myself and wanted to share it with the community because the problem was quite a hassle to diagnose. If the error message had at least indicated that the issue was due to an incorrect certificate, finding the solution would have been a much faster and simpler process; however, the error was very generic, making it confusing to know where to start looking for a fix. I admit that without the help of AI, I wouldn't have been able to solve it on my own.ibarrau's help did try to point me in the right direction, but the information was nearly 10 years old and outdated; it didn't address the certificate issue, which was the root cause of the problem.
Anyway, as I mentioned, I’ve resolved the issue myself, but I wanted to share this so that anyone else facing the same problem can save themselves hours of research and troubleshooting.
Hi. There are similar questions at the forum, maybe those can help. I guess this one is the most complete but there is a problem with the link that guided the process
Maybe this other article has the walkthough (translate it): https://blog.ladataweb.com.ar/conectar-power-bi-a-rds-postgres-en-aws/
I hope that helps,