Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Regular Visitor

Power BI running on "Efficiency Mode" in Windows 11 [JAN 2023]

I have updated my machine to Windows 11 in 2023 and I have noticed in the new task manager that has been released that Power BI is running in Efficiency Mode, meaning that the process priority is Low. There seems to be something wrong with the "msedgewebview2.exe" process, and when Efficiency Mode is on, the data refresh is extremelly slow.


There is a workaround, and that is right clicking on the process that is running in Efficiency Mode ("WebView2: https://ms-pbi..."), click "Go to details", right click on the selected process under the Details tab, set priority and select Realtime.



Any suggestions on how to solve this permanently? Does anyone know if this is a bug and if it has been reported? I haven't been able to find any documentation about the issue.





Frequent Visitor

I also am facing same issue, it occured when I installed upgrades provided by microsoft. One process running in efficiency mode. Whe I close this efficiency mode process some time whole teport is getting closed. It is very much annoying my work is getting impacted.

It has mae report very slow it seems.

New Member

Any solutions to this issue? Since upgrading Windows 11 with this efficiency mode, I'm unable to refresh any document locally !?

Those document take about 10 seconds to refresh when opened on the web, but on my PC it takes several minutes and then tell me it took too long !? Tried the above work-around, but it's still the same!


We have reports with parameters and one parameter need to be changed to "text" instead of "any" otherwise we can't change it on the web, however publishing doesn't consider the parameter change unless the report is refreshed once on the PC, and it's now impossible to refresh any report !?

Frequent Visitor

Hey @nrinaldiFrankly 

I have found a way to make this work. In the task manager click on the drop down arrow and see all the processes that are running under power bi. It is usually just one process that is running in efficiency mode and causing the problem. Just end this task and then try to refresh the data. It seems to work for me this way. 

Frequent Visitor

I am facing the same issue. It is really annoying that there is no way to disable this for power bi. I can seem to disable it for other applications but not for power bi. The data refresh is nightmare!!!

Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.