Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
BaronSdG
Helper V
Helper V

Join multiplying the rows only for some tables

Hi all,

 

I have an unexpected join result.

Below I have the right result in a graph, where for each gateway I have only 1 result for STP 

BaronSdG_0-1616427907448.png

 

But in this other graph, when I add STP column, the results become 4 instead of 1 because the column STP is adding the 4 possible status of stp (yes, no, blank, unk).

BaronSdG_2-1616427116293.jpeg

Why do I get this error?

 

I have the tables Components (middle table) and Components_mkt (right table) whose content must enrich the table on the left. The primary key is the 'gateway', and I have checked and for the tables component and component_mkt there is only one component name as it should be

BaronSdG_0-1616427116291.jpeg

 

I also tried to change the join from component and component_mkt with connectivity and component_mkt (*:1) but nothing changes

1 ACCEPTED SOLUTION

Hi Miguel, I tried recreating the table I needed and by changing the gateway column from the datasource to the one of the other table... No idea why it worked though, but it is filtering as expected..

View solution in original post

4 REPLIES 4
MFelix
Super User
Super User

Hi @BaronSdG ,

 

The information is very reduced, this can be from a variety of causes, can you please share a mockup data or sample of your PBIX file. You can use a onedrive, google drive, we transfer or similar link to upload your files.

If the information is sensitive please share it trough private message.


Regards

Miguel Félix


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Check out my blog: Power BI em Português



Hi Miguel, I tried recreating the table I needed and by changing the gateway column from the datasource to the one of the other table... No idea why it worked though, but it is filtering as expected..

Hi @BaronSdG ,

 

What was the column you were using on the many side or on the one side? When you have one to many relationships you must use the one side column/table onyour visualizations.

 

Don't forget to mark your answer as correct.


Regards

Miguel Félix


Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Check out my blog: Power BI em Português



Maybe that was it, but the issue is that I had another same table with the many side and it was working just fine...

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors