Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Medmbchr
Helper IV
Helper IV

Issue with currency rates decimal formatting from XE.COM to Power BI

Hi I would like to import currency exchange rates from XE.COM using a web import, the result normally should be as follow for MAD: USD US Dollar 0.09339564850488953 10.707136959894305 However I get numbers without decimals. Is there a way to counter this?

1 ACCEPTED SOLUTION

Looks like the query ignores the decimal point and returns the rates as very large numbers instead. It's likely due to your language/locations settings, where your Power BI is set to recognize "," and not "." as as decimal separator.

You could go to your settings and change that. But if you don't want to (it would affect the entire report), this might work:

- In the Power Query editor, go to the applied step "Navigation"

- Select the columns with the rates, find the button "Replace Values" and replace . with ,
- Go the the applied step "Changed Type"

- Select the columns with the rates, find the button "Data Type" and choose decimal number
 
I don't get this problem since I have different settings and my program recognizes "." as a decimal point, so sorry for not giving a better step-by-step with pictures.

View solution in original post

4 REPLIES 4
TomasAndersson
Solution Sage
Solution Sage

Could you share your query and/or how it looks in the Power Query Editor? Could it be that the Data Type is set to integer or something similar?

Hi @TomasAndersson 

 

Here is from where I get my data: https://www.xe.com/currencytables/?from=MAD

 

Here is how it looks on PowerQuery after importing from the web data source, I think something has to do with formatting:

 

Medmbchr_0-1669801978652.png

 

Looks like the query ignores the decimal point and returns the rates as very large numbers instead. It's likely due to your language/locations settings, where your Power BI is set to recognize "," and not "." as as decimal separator.

You could go to your settings and change that. But if you don't want to (it would affect the entire report), this might work:

- In the Power Query editor, go to the applied step "Navigation"

- Select the columns with the rates, find the button "Replace Values" and replace . with ,
- Go the the applied step "Changed Type"

- Select the columns with the rates, find the button "Data Type" and choose decimal number
 
I don't get this problem since I have different settings and my program recognizes "." as a decimal point, so sorry for not giving a better step-by-step with pictures.

It worked, I didn't think of these regional settings! Thank you

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.